Video Screencast Help

tape drive issue - barcode / media ID

Created: 13 Feb 2013 • Updated: 14 Feb 2013 | 5 comments
This issue has been solved. See solution.

Hello. I just added a tape drive (dell powervault TL4000) to a media server (Windows 2008 R2 Enterprise). In the device manager, I can see both drives. I've reinstalled / updated the drivers /rebooted the OS / restarted NB services on this media server.

My Master (same OS as media server) sees the robot / drive, adds in, can inventory it, but when I try to write to these tapes, or even 'label' them without verifying, my drive is instantly downed.

 

2/13/2013 1:45:19 PM - Info bptm(pid=1964) Waiting for mount of media id 1737L4 (copy 1) on server cwmedia.
2/13/2013 1:45:19 PM - mounting 1737L4
2/13/2013 1:45:19 PM - Info bptm(pid=1964) INF - Waiting for mount of media id 1737L4 on server cwmedia for reading.
2/13/2013 1:45:22 PM - Error bptm(pid=1964) error requesting media, TpErrno = Robot operation failed     
2/13/2013 4:43:10 PM - requesting resource NetBackup:1737L4
2/13/2013 4:43:10 PM - granted resource 1737L4
2/13/2013 4:43:10 PM - granted resource IBM.ULT3580-TD3.000
2/13/2013 4:43:17 PM - current media 1737L4 complete, requesting next resource IBM.ULT3580-TD3.000:NetBackup:1737L4
2/13/2013 4:43:23 PM - awaiting resource IBM.ULT3580-TD3.000:NetBackup:1737L4 A pending request has been generated for this resource request.
     Operator action may be required. Pending Action: All drives down.,
     Media ID: 1737L4, Barcode: 001737L4, Density: hcart3, Access Mode: Write,
     Action Drive Name: N/A, Action Media Server: N/A, Robot Number: 10, Robot Type: TLD,
     Volume Group: 000_00010_TLD, Action Acs: N/A, Action Lsm: N/A
   ________________________________________________

Is this pointing the finger at a robot hardware issue? The oddball part of this is my media ID is showing 6 digits (per my Media ID rules), barcode 8.

I've looked at every possible area in the dell powervault admin gui to change the number of digits it reads, however, there are no options for tweaking that. (unless Dell has done a bang up job of hiding it!)

For example, 8 digits show up under 'barcode', but 6 in Media ID. I made a media ID rule to grab only the first 6 digits of the barcode -

robot number 10      barcode  8  1:2:3:4:5:6

Ran a re-inventory, and the issue still happens. Am I barking up the wrong tree here?

 

 

 

Discussion Filed Under:

Comments 5 CommentsJump to latest comment

mph999's picture

You are on the right lines.

"or even 'label' them without verifying" - I was going to suggest this, but when I re-read your post, you have already done it.

Normally, if you get an issue with the media id I would expect to see a message like this :

Expected 1234L4 found AA1234

(which could happen if a tape with a tape label that was made on a system that used the last 6 characters for the media id was put into a system that uses the first six).

Pending requests are easily created with standalone drives - if the tape it wants to use is not in the drive, a pending request is created while NBU waits for someone to load it.

It may be worth just checking ;

If you look in NBU at the tape under media, check that is shows in the correct robot number and slot (check the slot in in robtest, s s command). - I am sure this is all correct, but sometimes it is worth starting from the very basics just to be double sure.

A label (witout validating is an excellent test, because we instant remove the any possibility of a media id conflict, simply because we don't care, we're going to overwrite it anyway ....

So, given that this is the test you are using, it could point at a library issue of some sort, I'd also check that there are no tapes stuck in the drives.

So what next.

Apart from the above, can you move the tape in question into every drive in the robot ?

If this works, it rules out a mechanical issue, and shows that the library can correctly respond to scsi commands (which is all robtest sends).

It could be worth looking in the logs.

Create ltid, tpcommand, robots dirs in volmgr\debug dir.

Create empty files called DRIVE_DEBUG and ROBOT_DEBUG in volmgr dir (make sure windows does not add any extension to the filename).

Put VERBOSE into vm.conf and restart ltid .

Logs should then show details, including windows event logs.

Hope this helps,

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
lovethatcheese's picture

Martin,

Just an update. After verifying I could move any tape around inside the tape drive (per your suggestion), I looked into the firmware again.

I was wondering why there was not an option in the Powervault admin gui for barcode reporting (namely, specify 6 or 8)...I had to roll back my library firmware - once done, I could see this option finally.

I changed this to 6, re-added the robot through the NB admin console, and I can now 'label' tapes..Each tape has since been relabeled and I just kicked off my first backup on this policy (this is the only media server with no MSDP pool - it's a small client, so it's going straight to tape).

As long as my backup job finishes with no issues overnight, I will close this thread.

Again, thank you for the quick response / assistance.

 

-Scott

 

_____

Current Environment - NB 7.5.0.4 on Master / Media Servers. 7+ and above on clients (Red Hat).

OS - Windows Server 2008 R2 Enterprise on all

All media servers have MSDP / attached tape drive / enabled SLP's

___

mph999's picture

Hi Scott,

Some libraries don't offer the option of change the number of characters in the barcode, they are set permantly on 8.  I am not fmailiar with that model of library, so did not know if the option should be there or not.

It looks like not only should the library have been displaying this option, but something else in the frmware was preventing it working correctly. because even if display 8 characters, it should have worked.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
lovethatcheese's picture

Martin,

I agree - there was something fishy going on that the rollback of firmware did the trick. Either way, last night went through fine, so I should be all set!

_____

Current Environment - NB 7.5.0.4 on Master / Media Servers. 7+ and above on clients (Red Hat).

OS - Windows Server 2008 R2 Enterprise on all

All media servers have MSDP / attached tape drive / enabled SLP's

___