Video Screencast Help

Tape Drives are down

Created: 03 Dec 2013 • Updated: 24 Jan 2014 | 9 comments
This issue has been solved. See solution.

Hello All,

We are using NBU 7.0 on W2K3, and the tape drives were went down, and i found some logs in eventvwr as below, could any one help me to know what was the RCA for this error, and when i tried to up the drive they cam eto normal state.

 

 

job Detailed status:

12/4/2013 3:00:07 AM - requesting resource TapeLibraryGroup1
12/4/2013 3:00:07 AM - requesting resource ie03nas004.NBU_CLIENT.MAXJOBS.ie03nas005
12/4/2013 3:00:07 AM - requesting resource ie03nas004.NBU_POLICY.MAXJOBS.NAS005_DRIVE_G
12/4/2013 3:00:07 AM - Error nbjm(pid=2984) NBU status: 830, EMM status: All compatible drive paths are down, but media is available
drive(s) unavailable or down(830)

 

 

Eventvwr logs

emmlib_UpdateDriveRuntime failed, status=258

TLD(1) key = 0x4, asc = 0x81, ascq = 0x9e, UNKNOWN ERROR, KEY: 0x04, ASC: 0x81, ASCQ: 0x9E

Operating Systems:

Comments 9 CommentsJump to latest comment

rk1074's picture

Are you using the windows drivers or symantec's drivers for the tape device? It is recommended to use symantec's version of the device driver.  Look here for your device and corresponding driver::

http://www.symantec.com/business/support/index?page=content&id=TECH51096

 

Also please hare the below logs:

bptm log on  the media server (/netbackup/logs/bptm

 /usr/openv/netbackup/db/media/errors

 

john@12's picture

Hello All,

The Drives are automatically going down if we run any backups, and i deleted drives and robots from NBU end and tried to configure from wizard, but it was not showing any error but its showing as wait while devices are autodetected for more than 25 min, and im not able to run the Inventry from Libary end and also drive cleaning from Libarry end im facing error attached below. Could any one help on this.

 

 

cln.png

 

 

rk1074's picture

Potentially an issue with the robot. need to chk with your vendor.

If its a HP make ,check this out:

http://h30499.www3.hp.com/t5/Tape-Backup-Small-and-Medium/Robotic-Failure-Code-9E-09/td-p/1033682

mph999's picture

TLD(1) key = 0x4, asc = 0x81, ascq = 0x9e, UNKNOWN ERROR, KEY: 0x04, ASC: 0x81, ASCQ: 0x9E

You have a hardware problem of some sort.  This message is sent from the drive/ library, not NetBackup so you will need to contact your hardware vendor.  In this case the message is coming from the library.

 

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
Marianne's picture

I agree with above advice - forget about NBU. Log a call with your hardware vendor.

Once hardware is fixed, delete 'old' devices (Medium Changer and Tape drives) from Windows Device Manager and then perform a rescan.

Check that Removable Storage service is stopped and disabled.

Only then perform a scan with NBU.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

I would get onto the library web interface first to see if any tapes are stuck in the drives - if so them move them out using the library GUI

Once done reboot the library and wait for it to show as "ready" or "online"

Then reboot your media servers

Then try again

Check for alerts on the library itself and call the vendor if there are issues

Stop and Disable the removable storage service on the media servers and add the AutoRun registry key with a value of 0 - see this tech note (needs a reboot) : http://support.microsoft.com/kb/842411

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

john@12's picture

Hello All,

 

I raised acase with DELL, they collected some logs and they asked me to upgrade the Firmware im doing the same.

And more thing Marianne how and where to check "

"that Removable Storage service is stopped and disabled."

john@12's picture

Hello All,

Is this below path is correct to check to "that Removable Storage service is stopped and disabled.""

 

 

  1. Click Start, type services.msc, and then click OK.
  2. In the right pane, double-click Removable Storage.
  3. In the Startup type list, click Manual, and then click Apply.
  4. Click Start, and then click Stop.
  5. In the Startup type list, click Disabled, and then click OK.
quebek's picture

Yes, that is exaclty what needs to be done to have this service being disabled...