Video Screencast Help

Tape Drives Offline!

Created: 18 Jun 2013 • Updated: 11 Jul 2013 | 6 comments
This issue has been solved. See solution.

I have an attached tape library which has been working well for a few months since we installed it.

It has 4 tape drives inside.

Today 1 drive went offline. Then another. And this afternoon a 3rd one went offline.

When I bring a drive online via the All Storage GUI, it falls back offline in a few minutes.

If I run a cleaning job to clean the tape (just in case that was the issue) it goes offline while trying to clean.

Operating Systems:

Comments 6 CommentsJump to latest comment

teiva-boy's picture

Any diagnostics you can run from the library manufacturer?  Most offer some level of tools...

Any possible firmware updates for the unit as well for both the library and drives?

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) "We backup data to restore, we don't backup data just to back it up."

pkh's picture

When you test the library with the manufacturer's diagnostic utility, make sure you select the write test and that you have stopped all the BE services beforehand.

If the diagnostic does not turn up any error, try this

1) Delete the library from BE
2) Stop the media server and the library. Remove and re-seat all the connections from the tape library to the media server.
3) Start the tape library
4) Start the media server
5) Ensure that the library and tape drive is recognised and functioning correctly in the Windows Device Manager. The library should appear as an Unknown Medium Changer with a Microsoft driver and the tape drive should have a Symantec driver.
6) In BE, install the library if necessary. 
Jaydeep S's picture

@JustTryinToGetItToWork Are you getting any errors about the hardware in the Windows event viewer (event ids 7, 9, 11, 13, 15) This would help you to dignose the problem.

JustTryinToGetItToWork's picture

Thank you for your ideas. I decided to try the easiest thing 1st which was to turn off the Server. Turn off the Tape Library. Start the Tape Library. And restart the Server. And it ended up putting 2 of the 3 drives online.

Interestingly, my Robotic Library shows 5 tape drives! when before it only had 4!

See attachment.

Hmmm. I went into Device Mgr and saw that I had previously disabled one of the drives as a part of troubleshooting. (well, I think i did)

Anyway, now I am simplying looking to get the Tape drive 0003 to accept a Duplicate job. Currently, when I send a job to Tape drive 0003 I get the message of No Idle Devices. That erro has quickly changed to "Error- Mount Failed. Physical Volume Library found.

I will update and let you know what I find out.

Tape Drives Offline.JPG
Jaydeep S's picture

Check in Windows Device Manaer if you are able to 4 Tape drives or if the 5th is visible here. If the 5th is visible, then you would have to uninstall the drivers, remove all the drives and the reboot the server to add them back. Make sure that all the Tape drives visible there are using Symantec Tape Drivers.You would also have to remove the RL from BE and restart the services to allow autodetect.

If the device manager is showing only 4 drives, then confirm that all the drives are using Symantec Drivers. You could use the Tapeinst.exe from Backup Exec program folder to update the drivers on all the drives. After this, Disable and remove all the Tape Drives from BE devices tab and restart the services. They should now be auto detected back again.

JustTryinToGetItToWork's picture


I pretty much did what Jaydeep said...maybe a step or 2 less.

In essence, I used the B. Exec Storage interface and selected "Configure Storage", then "Tape Storage" and I reinstalled the drivers using tapeinst.exe.

This worked to get my last drive online.