Video Screencast Help

Tapes not filling up and compression is poor or 1:1

Created: 06 Nov 2012 • Updated: 28 Jan 2013 | 3 comments
This issue has been solved. See solution.

I've got an interesting problem here with tapes.  We're running BE 2012, fully patched.  We write to disk (Data Domain) and at month's end, we duplicate to tape on a Quantum Scalar 50 library (using Symantec drivers).  This process works, however we're finding that each tape on the library says it has between 25-30GB of free space, yet BE reports it as full.  We have infinite appends on as well for the media sets.

Additionally, most tapes report 1.0:1 compression.  A few report 1.1:1 and one reports 1.8:1.  Compression is lowest on tapes with more AVVI backups duplicated to them.  The tape with 1.8:1 compression has mostly a backup using NDMP from a NAS, but also has some physical servers written to it and some virtuals.

It seems like we're taking a double hit here, loosing several hundred GB of space due to tapes not filling up.  And then when you add in the poor compression, we're using more tapes than necessary. 

Any suggestions?  It seems like AVVI backups when duplicated, to not compress on tape.  Anyone else seeing this?

 

Thanks in advance!

Comments 3 CommentsJump to latest comment

Larry Fine's picture

Since BE is reporting that the tape is full, I would assume it IS full.  BE writes to a tape until the tape drive reports to BE that the media is full.  At that point, BE stops writing and all the buffers & caches flush out.  The space that is still available is for those buffers to get written and for overhead.  The LTO group or the tape drive (or media?) vendor determine when BE gets told that a media is full.  What size cartridges are you using?  25-30 GB is probably a VERY low percentage of the total capacity.

Compression is also a hardware function.  As long as comression is truned on, there is nothing BE can do to control the compression ratio.

If you find this is a solution for the thread, please mark it as such.

SOLUTION
Moltron1's picture

Thanks for the info.  I agree on compression, and all the settings for compression are enabled in Backup Exec.  I'll inquire with our tape library vendor. 

The tapes are 800GB tapes, so 30GB is a small percentage.  I did open a case on that with Symantec, and the technician couldn't quite explain it.  It went to Advanced support.  The library itself reports the same amount of free space that BE does.  Based on what you said I should probably take up both issues with the tape library vendor. 

fsbofh's picture

Ah, wait, look at the Datadomain-Appliances's setting.

There's a "Split data stream every"-setting, which is default 50 GB, I think.

I suppose Backup Exec won't stream a new "file" onto the tape if it does not fit on it. But that's just an assumption.