Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Task Server Issue on Clients

Created: 07 Sep 2012 • Updated: 05 Apr 2013 | 5 comments
This issue has been solved. See solution.

We just opened a new site and I created an new site server, no problems.  Looks like that is all good.  We are having problems with clients and the task service.  When I click on the "Task Status" tab, I either get services shutting down or received requests to stop running tasks.  I have clicked the reset agent button on some of these and have also run this command regsvr32 "C:\Program Files\Altiris\Altiris Agent\Agents\Client Task Agent\Client Task Agent.dll on them, no luck.  The error message I am receiveing through RAAD when I run diagnostics on the client is below.  What can I do to reolve this issue?

<event date="Sep 07 23:54:41" severity="1" hostName="PE-DC03" source="Client Task Agent" module="client task agent.dll" process="AeXNSAgent.exe" pid="1516" thread="4044" tickCount="17984590"><![CDATA[CTaskServerNetCommsConnection::ReadServerListDocument():  There are no Task Servers available for this computer]]></event>

 

Comments 5 CommentsJump to latest comment

BigDaddyPS's picture

At a further look into this issue, my Altiris Invetory Agent, Altiris Server Inventory Agent, and Altiris Software Update Agents, are not loading.  What do I need to look to at see that these get loaded?

Nagesh Singh's picture

Hi BigDaddyPS,

 

have you got the solutions on this?

Thanks & Regards,

Nagesh Singh

 

BigDaddyPS's picture

Yes, we have resolved this issue and agents are loading properly now.  A couple of rebbots and we had to wait a bit.  The site has a very slow link to it and it just took a bit longer than usual.

BigDaddyPS's picture

The link to this city i just found out the last mile is wifi.  The site is in India and this is what has been causing my agent loading problems the whole time from what I can see.  The link has been continuously dropping multiple times a day and it really seems that due to lack of the computers being connected with the WAN and the speed of the last mile being slow due to the wireless connection.  This is also effecting or DNS and AD replication and giving us fits.  So it makes sense that this would be the issue.

SOLUTION