Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Task Service on Site Server won't upgrade to 7.5

Created: 15 Nov 2013 • Updated: 21 Nov 2013 | 7 comments
lko's picture
This issue has been solved. See solution.

The task service on my site server doesn't appear to be upgrading to version 7.5. How do I get this to upgrade to the latest version?

Operating Systems:

Comments 7 CommentsJump to latest comment

Igor Perevozchikov's picture

Hi Iko,

1. First you need to enable Symantec Management Agent upgrade rollout policy.

-- Open Symantec Management Console -> click "Settings" -> click "All Settings" -> expand "Agent/Plug-ins" folder -> expand "Symantec Management Agent" folder -> expand "Windows" folder -> expand "Site Server" folder -> enable Symantec Management Agent upgrade rollout policy and receive it on Task service computer via refresh policy.

(Depends on which OS is running your Task Server, x86 or x64)

SMA1.jpg

2. Whan Symantec Management Agent will be upgraded to 7.5 version, then you will need to enable "Task Service Upgrade" rollout policy

-- Open Symantec Management Console -> click "Settings" -> "Notification Server" -> "Site Server Settings" -> expand "Site Management" -> expand "Settings" -> expand "Task Services" folder -> expand "Advanced" folder -> enable "Task Service Upgrade" rollout policy and receive it on Task service computer via refresh policy.

(Depends on which OS is running your Task Server, x86 or x64)

SMA2.jpg

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
lko's picture

Thanks, I already had all of the SMA and the Task Service 32 and 64 set to upgrade and it still reads version 7.1.  The SMA on the site server upgraded to 7.5, just not the task service.

Igor Perevozchikov's picture

Ok. Then we need to make sure that "Task Service Upgrade" rollout policy was delivered to your Site Server computer and at least executed with success or failure.

1. Make double mouse click on SMA systray icon

TaskUpgrade1.jpg

2. Open Software Delivery tab -> check following checkboxes

-- "Show scheduled tasks and packages"

-- "Show internal tasks and packages"

-- "Show expired packages"

TaskUpgrade2.jpg

3. If you will see "Task Service Upgrade" rollout policy, then make mouse double click on it and then will appears separate window where we can see when this policy was received and executed and with which "Exit Code"

TaskUpgrade3.jpg

Note:

If you will don't find this "Task Service Upgrade" rollout policy, you'll need to check "Resource Target" filters in "Task Service Upgrade" rollout policy on Symantec Management Console.

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
lko's picture

It shows that it is version 7.5 and it installed when viewing it on the client. However, my concern is when I view the Task Service on the site server it shows as the old version.  I'll attach a screen shot.

ss.JPG
lko's picture

A reinstall of the Task Server fixed this issue.

SOLUTION
ukanoldai's picture

Hello Iko,

could you tell me how you reinstalled the task server? because we were in the same issue but couldn't resolve it, it keeps being in 7.1 like you were.

regards

lko's picture

To reinstall the task server, under Settings > Notification Server > Site Server settings, locate your site server and click on it, then click Install/Remove Services.  Deselect the task service check box to uninstall the task service.  Force check in on the task server to start the process, then run the resource membership update (full).  Once you have confirmed that the task service is no longer installed, click the install/remove services again and check task service to install it.  Then force the server to check in and run resource membership update again.