Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Task status shutting down

Created: 28 Nov 2012 | 4 comments

Hi All,

We have around 1250 remote location and one head office, Each location have own domain controllerand there is no trust relationship between anyother domain inlcuding our head office. so name resoultion is not possibile

i installed the Altiris agent in the all the system and the systems reporting the basic inventory. i have configured the NS to use Alternate URL for accessing NS in that i have given ip address of the server name.

when i opened the SMA, task status shows "shutting down" and not able to push any task.

 

Comments 4 CommentsJump to latest comment

andykn101's picture

The IP address of the NS will not necessarily help the Task Agent find the nearest Task Server.

Use the Remote Altiris Agent Diagnostics (RAAD) toll to look at the log of the client:

http://www.symantec.com/docs/HOWTO21449

Maybe try a hosts file entry for the local Task Server to help troubleshoot.

 

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

ba_vivek's picture

found in SMA log that SMA trying to reach the NS using FQDN name but there is no DNS entry, so its getting failed.

other than host entry, is there any options in altiris console to change the client communication should use only IP address.

because hostentry is such difficult task in our environemnt.

Robert Steinle's picture

Hi,

 

  1. Go to Settings->Agents/Plug-ins->Symantec Management Agent->Settings->Targeted Agent Settings
  2. Click on the applicable policy (e.g. “All Desktop computers (excluding 'Site Servers')”)
  3. Select “Advanced” tab
  4. Enable “Specify an alternate URL for the Symantec Management Agent to use to access the NS”
  5. Specify “Server Name” in format ‘NsIP:Port’ (without ‘’), port is required only if you’re using non-default (not 80 and not  443) ports.
  6. Change “Server Web”, like ‘http://NsIP:Port/Altiris/’ (without ‘’), if you’re using SSL, then change ‘http’ to ‘https’.
  7. Repeat for every applicable policy in p.2
  8. Refresh policies on the clients or install new agents

 

Of course this will help only for new clients. Agents, which already have DNS problem, will not be able to get new policy, because they don’t see NS Server.

 

Also, it’s not required to configure domain trust to resolve machines out of any particular domain, you can use DNS Forwarders for this, check - http://technet.microsoft.com/en-us/library/cc782142(v=ws.10).aspx But configuring this for 1250 environments would be painful.

Regards,

Robert Steinle

Symantec Corporation

 

For Forum threads, please click "Mark as Solution" if answered.

ba_vivek's picture

Hi,

Since i'm using default port, so i have configured the server alternate URL using NS IP address.

i made this configuratio earlier itself, then only i made the deployment