Video Screencast Help

Tasks failing after upgrade to 7.5 HF2 : Unable to get a .NET type

Created: 18 Dec 2013 • Updated: 19 Dec 2013 | 6 comments
This issue has been solved. See solution.

Applied OS updates and 7.5 HF2 update yesterday. After update, receiving the following error when attempting to run Script or software install tasks:

An unknown exception was thrown.

System.Exception: SerializedParameterCollection::ToValue(): Unable to get a .NET type named Altiris.TaskManagement.Common.Tokens.TokenDefinitionCollection, Altiris.TaskManagement.Common, Version=7.5.1672.0, Culture=neutral, PublicKeyToken=99b1e4cc0d03f223 at Altiris.DotNetLib.Collections.SerializedParameterCollection.ToParameterValueCollection() at Altiris.ClientTask.Server.Data.ClientTaskServerExecutionInstance.get_InputParameterValues() at Altiris.ClientTask.Server.Execution.ClientTaskEngineExecutionThread.LoadInputParametersFromTaskInstanceParent() at Altiris.ClientTask.Server.Execution.ClientTaskEngineExecutionThread.Execute() at Altiris.TaskManagement.Common.Execution.Engine.TaskExecutionEngine.ProcessTaskExecuteOperation(TaskInstanceRequest request, TaskEngineExecutionThread thread)

Operating Systems:

Comments 6 CommentsJump to latest comment

burndtjammer's picture

Looks like I need to work on my reading comprehension...

If the task server plugin is 7.5.1670 then you need to make sure the policy upgrade is turned on and then it should update fine to 1672.

     ■ In the Symantec Management Console, click Settings > All Settings. In the
left pane, expand Notification Server > Site Server Settings, and then locate
and turn on the upgrade policies for various site server plug-ins.

If the task server plugin is 7.5.1671 then you not only need to make sure the upgrade policy is turned on but also need to reboot the server OS.

Known issues

The following are the known issues for this release. If additional information about
an issue is available, the issue has a corresponding article link.

Table 1-8 Known issues for Task Server

Issue Description Article link
If you upgrade a remote task server to a given version, and then N/A
upgrade to a newer version, the second upgrade does not succeed.
For example, this problem appears if you first upgrade a task server to
7.5 HF1, and then to 7.5 HF2.

Restart the remote task server computer after each upgrade.

Molsonalex's picture

Thanks a lot burndtjammer! was also getting this issue even though the upgrade rule was turned on. Gonna reboot the task server and see if it fixes my issue

Molsonalex's picture

hum... even after a reboot of all site servers, plugins on my site servers are stlll at version 7.5.1671.

The Task Service Upgrade (x64) is enabled but has a count of 0 computers requiring the upgrade

Molsonalex's picture

I finally had to clone every single upgrade tasks related to site servers so the Symantec Management Agent site server tasks, Depployment Site Server Components, etc and apply it to Site Server filter instead of Site Servers requiring upgrade. Even after doing a full update to recreate OU's, Filter and Target membership wouldn't change that so I had no other choice than to clone each plugins tasks... anyway, now working and glad I fixed it

burndtjammer's picture

There were a couple that i still had issues with.  The task said it completed on the agent but the plugin was still from HF1.  Ended up having to run the install manually for the 3 or 4 this happened to.