Video Screencast Help

Test import/restore multi-fragment backup

Created: 10 Oct 2012 • Updated: 02 Nov 2012 | 2 comments
This issue has been solved. See solution.


I'm practising our Disaster-recovery, and have hit a small snag.  We have a backup job that runs over 2 tapes, creating 2 fragments.

When I come to restore the Phase 2 import of the second fragment (tape 2), the phase 2 import tells me theres nothing to import, yet, if I try browsing the client restore, some of the files that I believe are in the second fragment aren't being listed.  Heres what I'm doing in my process:

  1. Run the backup
  2. Run an expire of the 2 tapes. bpexpdate -m <tape> -d 0  (UBI033, 1st and UBI046, 2nd)
  3. Delete the tapes from the catalogue
  4. Re-inventory the robot and it detected the two "new" tapes ok.
  5. I then run a P1 Import on both tapes
  6. If I then Try an Catalog-Import for UBI033, I see the Backup ID I expect. If I run it for UBI046, it tells me nothing matches. I've checked the date range and everything else is set to All <*>

During the P1 of UBI046 I see in the Results log text like:

Found existing image information for client <machine>, policy <polcy> and schedule Full    (changed names here).
Recreating Copy 1, fragment 2 information for image
Creation of database information for import of media id UBI046 complete

So it looks like the fragment 2 data of P1 import went ok.I'm repeating the test now, but I believe its missing Fragment 2 data because I don't see able to run ghe P2 import of UBI046.

Before I gather logs, have I got anything wrong in my procedure ??

Comments 2 CommentsJump to latest comment

Nathan Kippen's picture

Phase 1 import needs to be ran on both tapes.

Phase 2 import - Select the "import" option from the dropdown.

Search for your backup using date range and client name... etc

Right click on your backup image name listed in the search results and chose import.

Symantec Certified Specialist
Don't forget to vote or mark solution!

mph999's picture

Don't search per media for the phase 2 bit, just leave it set to all.


Regards,  Martin
Setting Logs in NetBackup: