Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

testing BE 2010 R3 trial on w2k8 R2 (x64), tape compression low

Created: 15 Feb 2012 • Updated: 16 Feb 2012 | 21 comments

Hello,

We are testing the trial of Backup Exec 2010 R3 on our primary domain controller running Windows 2008 R2 equipped with HP DAT 320 (internal USB) tapedrive. I have just discovered that I can't fit the usual size of data onto our 160/320GB tape with BE2010 ... the compression ratio is very low, around 1.1:1 and backup task asks for another tape...

We use it for last night backup only (everyday, no rotation), mostly for having a fresh backup of server system files along with Active Directory and SQL instances ... production files are replicated to other w2k8 servers and NAS so need to backup everything to this tape.

Is there any known problem with BE 2010 R3 inefficiently using media compression on HP DAT 320 tapedrives?

asking because before we used a software whcih came with tapedrive, it was HP Data Protector Express 5.0 Basic and I was able to fit much more information to the same 160/320GB media when using that software, now I can't seem to be able to achieve that with BE 2010 R3 ...

lastly, is there any way the Symantec BE 2012 beta/trial becomes public anytime soon? I signed up a while ago for it, but it seems so far it is released only to partners and people with current maintenance plans on BE software - we don't have it, we are considering a switch to Symantec for our backup needs ...

Thanks.

Comments 21 CommentsJump to latest comment

Ken Putnam's picture

From the Devices Tab, right click the drive \properties

Verify that enable compression is selected.  Also read through the manual for the tape drive and see if there is a compression on/off switch on the drive itself

You can also download the manufacturer's test utility and do a few runs.  (HP has LTT, Library and Tape Tools for example)

If this response answers your concern, please mark it as a "solution"

6ft_under's picture

I have just checked the Device driver properties and it says Compression Cabale = TRUE, but another paramtere below it named Compression Enabled says FALSE ... weird ... I haven't changed drivers for this tapedrive when removing the HP DPX5.0 ... it seems that is the reason why Symantec software can't use compression (HW compression is checked in task properties of BE2010R3) ...

I have no idea if that driver property was TRUE before I uninstalled HP software, but something is telling me this is the reason why the media compression sits at minimal 1.1:1 ratio (pretty much no compression).

wondering what's up with that ...

will try re-installing HP tapedrive drivers and see if this switch toggles from False to True (I can't change it myself, option is grayed out, only reporting the state, not allowing to change it).

Larry Fine's picture

Hardware Compression is a feature that is either on or off.  Since you are getting SOME compression, it is obviously "on".  The compression ratio is determined by the hardware (not much you can do about that) and the source data.  Any chance you were backing up different data when you were using the other software that achieved a higher compression ratio?  Different data can have dratically different compression ratios.

If you find this is a solution for the thread, please mark it as such.

6ft_under's picture

When using HP software (and their tapedrive drivers) I never had to check anything about comrpession settings, it was just working very well.

Data type is same, only data size could have grown by a little bit (a few GB, new SQL instance was installed, WSUS downloaded some updates, etc.), but it was still fitting 160/320GB media when using HP software. Now I can't fit even 175GB onto the media when using BE2010R3 ...

timgarbim's picture

I made a small research and your driver support hardware compression, so probabily the backup exec is using it, you MAY try using the software compression and see if it gets better, but as Larry said, it depends of the data you´re backing up.

6ft_under's picture

Yup, the drive is definitely capable of compressing the data (up to 2:1 ratio) and that's how it worked by default with HP DPX5.0.

not sure exactly why different vendor's software can't use it, but I need to investigate the driver settings as one driver property says Compresion Capable TRUE, however Compression Enabled property says FALSE - have no idea how it was set before uninstalling HP DPX5.0 though).

Let me check 2 other (older) HP servers with different model HP drives, but they should have similar properties in Device Manager drivers.

CraigV's picture

...if you were getting compression on the older drive, have you made sure that the current drive is running with the Symantec drivers? If not, consider installing these.

@timgarbim: Please don't paraphrase what other people post before you...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

6ft_under's picture

right, that's another good point. drive is running HP drivers (it's an HP drive), where should I look for Symantec drivers for my HP drive?

6ft_under's picture

OK, I have just checked 2 other (Proliant ML350 G4p) servers using older internal SCSI Ultra 320 tapedrives and in fact "Compression Enabled" parameter is set to TRUE on HP DAT72 in that server and also other server running HP Ultrium LTO 400GB has no such parameter in driver properties (but compresion works anyways). Both other servers are using HP Data Protector Express 4.0 SP1 software that came with HP tapedrives ... running under Windows 2008 SP2 x86 .... HP driver setting coincidence or a bug? if a bug than what's cauing it, HP driver or Symantec BE2010 R3 software?

Honestly I smell something fishy about HP here regarding the new Proliant ML350 G6 server and their HP DAT 320 tapedrive ... how come the compression was working great when using HP DPX 5.0 Basic software and after switching to Symantec it doesn't work at all anymore ... would it be possible that HP DPX 5.0 software toggles the compression setting for HP drives upon uninstallation of HP backup software? kinda scary if it was true ... hopefully this is not the case ...

... or the other way around, maybe installing Symantec BE2010 R3 has broken something (software wise) regarding tapedrive compression? I don't see how though, since I re-installed the HP driver and the same compression problem persists.

EDIT:

I have re-installed the latest HP StorageWorks 3.5.0.0 driver for Hp DAT 320 and still I see the "Compression Enabled = FALSE" in tapedriver driver properties ...

Does Symantec have their own driver for this tapedrive? I'd like to try it out, but don't know how or where from.

6ft_under's picture

never mind, I think I found how to switch from HP drivers to Symantec ones:

http://www.symantec.com/business/support/index?pag...

will give it a shot soon.

EDIT:

:( no go

"Symantec does not supply tape device drivers for USB tape devices.

Device drivers for USB tape devices should be obtained from your device vendor."

back to square one :(

any ideas?

6ft_under's picture

I've got it working :)

at least the device driver property "Compression Enabled" now shows "TRUE" :))))

I decided to wipe the device drivers clean from Windows 2008 R2 server and after restart I denied Windows Update driver and also didn't use the HP Version Control Repository driver package.

Instead I went straight to vendor (HP) driver download page and took a fresh package (same version I had before) of StorageWorks 3.5.0.0 driver for Windows servers.

http://h20000.www2.hp.com/bizsupport/TechSupport/S...

but then ... I noticed something strange, a RECOMMENDED HP Storage Tape Firmware for Microsoft Windows  (what is this?), version 3.6.0.0 - and here is the strange thing, HP Version Control Repository didn't detect this recommended install before on this particular server (it did for 2 older ones), and it still doesn't even after it was installed.

On top of that I use HP StorageWorks Tapedrive Library & Tools (now ver 4.14) for checking and updating the tapedrives firmware. the funny thing is that it was already updated to version VUA8 (and still is) as before, no change here hmmmmm

... so the real question is ... what is the "HP Storage Tape Firmware for Microsoft Windows" if it is not a Windows device driver (different package) and not a firmware in terms of flashed piece of program reported by HP LTT software? firmware for ... what exactly?

I guess I will never know, but the good thing is that now the HP DAT 320 (internal USB) Hardware Compression is enabled also in the Windows driver properties, so Symantec BE2010 R3 should be able to finally make use of it just like HP DPX5.0 was able to (through some other means) :)

I hope it helps others running into the same trouble!

Special thanks to Ken Putnam for getting me onto right tracks with troubleshooting this one :)

Case closed ... and finally SOLVED :)

6ft_under's picture

OK, bad news. It's SYmantec BE2010 R3 screwing up media compression. it's just happened again after I started a Test Run on freshly re-created Backup Job using a fresh re-discovered device (old one went offline in BE2010R3 after reloading drivers).

and so, same problem again. Media Compression is disabled permamently in driver settings right after trying to run a Backup Job using Symantec BE2010 R3. something is not compatible here.

Uninstalling Symantec BE2010 R3, I guess we won't be buying it if it can't support such a basic feature as media compression. pretty ridicolous if you ask me.

Ken Putnam's picture

Sorry about that

I'll go ahead and set the support flag to draw the attention of the Symantec Techs for you

If this response answers your concern, please mark it as a "solution"

6ft_under's picture

that's OK, thanks. somehow BE2010 R3 doesn't like my HP DAT 320 (internal USB) tapedrive. it keeps permamently disabling the Compression Enabled property in device driver (using vendor driver, symantec doesn't provide one).

CraigV's picture

Symantec don't supply USB device drivers which could be a reason for not getting proper compression. You'd most likely get this using SCSI/SAS.

Why not download another vendor's application and try that...if it still doesn't work, then it's the drive. The G6 server isn't that new anymore, but I doubt that has anything to do with it...it's a USB port after all.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

6ft_under's picture

yeah, I learned that the hard way that Symantec doesn't provide USB drivers. it also seems it can't correctly work with USB tapedrives running vendor drivers either.

I switched back to HP Data Protector Express 5.0 Basic software and media compression works normally and stays enabled in device driver properties.

We will be upgrading this bundled software to full license soon to cover SQL instances as well (was one of reasons why I wanted to trial a Symantec instead).

pkh's picture

You can trying using software compression.  If you get roughly the same compression ratio as hardware compression, then it is your data that cannot be compressed further.

6ft_under's picture

thanks, I know. type of data we backup is lowering the ratio too, since we now have more windows updates in WSUS folder now (recently added support for win7 stations) and that makes the difference too.

however HP software can make use of hardware compression on thei HP DAT 320 drive, symantec can't.

I'd rather make use of hardware compression since it's supposed to be supported. this way the work load on server CPUs will be much lower while backup is running in background, not that we really need it, because we have nightly backups while nobody is here, but who knows, sometimes I needed to run an emergency backup during business hours, so I could proceed with something else later, etc.

Larry Fine's picture

Based upon your first post "the compression ratio is very low, around 1.1:1" your compression IS working.  If it was not working the ration would be simply 1:1.

Software has no control over the compression ratio achieved.

Here is a technote on how to confirm if it is working  http://www.symantec.com/docs/TECH50960

If you find this is a solution for the thread, please mark it as such.

6ft_under's picture

really, a one-time compression event only? 1.1:1 on first recorded tape and then it stays disabled in device driver settings (and cannot be changed until server gets restarted and sometimes driver re-installed). LOL!

right after the first job, the Compression Enabled boolean stays false permamently in driver settings (was enabled before the first run) and never happens again ... as I mentioned, I don't have such problem with HP DPX 5.0 that's why I have no other choice as stick to it ... please, don't tell me SYmantec works right, because it DOES NOT. seems it can't cooperate properly with USB drivers for HP DAT 320, the sole reason why I no longer use it (uninstalled, sorry).

6ft_under's picture

OK, just a quick update proving that something is up between HP DPX 5.0 vs BE2012 R3 software epr the selected backup count or the actual compression.

I have switched back to HP DPX 5.0 (now having a full license also covering SQL instances backup) software and again the same (!) selection of backup is going through without trouble with plenty of free space left on the tape.

now, how is this possible? compression issue? I would really like to know what the problem was...

not sure, but I remember that Symantec BE2012 R3 was reporting around 220GB of data for backup upon (same) selection and it was resulting in full tape at compression disabled 1:1 or comrpession at 1.1:1 (only at first run, then staying disabled for every other run).

Now with HP DPX 5.0, the exact same selection of SQL instances, System State and file folders, I see that only 117GB was actually written to the 160/320GB media ... unfortunately HP DPX 5.0 doesn't show the data tape actual compression ratio, but clearly things are different.

BE2012R3 was trying to write 220GB (after unchecking some folders I was able to lower it to 175GB and it was still too much, but that's not the point) while HP DPX 5.0 (selected everything, just when I did in BE2012R3 which resulted in 220GB count) writes 117GB... all things are supposedly exactly same per selection. what's up???