Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

time assign column in media

Created: 03 Oct 2013 • Updated: 03 Oct 2013 | 9 comments
This issue has been solved. See solution.

when NetBackup goes to use a tape and mounts it, it gets assigned -
assigned means that NetBackup took a scratch tape with no assigned date and tried to use the tape today - does not mean that it wrote to it.
Now when NetBackup writes to the tape it gets an images ( this does not change the assigned date).

if the backup is good then the tape has an assigned date, and has a good images.

http://www.symantec.com/connect/blogs/understanding-how-nerbackup-writes-tape

Media gets time assigned when it is mounted on a drive for first time or when a good image has been written on a tape?

Operating Systems:

Comments 9 CommentsJump to latest comment

revaroo's picture

It gets assigned when it has been written to for the first time. I could mount the tape with robtest but it would not be assigned within NetBackups records.

noazara's picture

@Revaroo:Media  gets assigned when firstly it is mounted and assign time when data has been written onto it?

Am i correct?

revaroo's picture

Yes that is correct.

Marianne's picture

The moment that the resource broker identifies a tape to be used by a media server, it Assigns it to the media server and add Assign Time in the volume table of the EMM database. If there is a problem with the media, for example write-protected and gets frozen as a result, the Assign Time along with the Frozen status remains - no data, no image written.

The normal behaviour is that the Assign Time is more or less the same time as first image written.

There is no need for forum questions like this - you can easily enough confirm this in your own environment by checking output of 
nbemmcmd -listmedia -mediaid <media-id> 
on some of your Assigned tapes.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

revaroo's picture

I just did a test. I let test 1 work completely:

Time Assigned:                  10/03/2013 06:36
 
I then Suspended that tape
 
Test 2 I killed bptm with a loop to stop it writing:
It still assigned the time to the new tape:
 
Time Assigned:                  10/03/2013 06:50
 
suspended that tape
 
 
I then did another test, and killed bpbrm before it could get going, no tape assignment was made to any new tape. So it seems a soon as bptm is going (and writing- the previous kill may not have killed it before it started writing) it's then Assigned.
 
noazara's picture

@Revaroo:So what is the final conclusion?

revaroo's picture

From my test, that as soon as the tape is mounted and written to, the assign time is set. It probably happens just prior to the actual write.

I wouldn't worry about it too much. It will be set at/around the time of the FIRST write to that tape

SOLUTION
noazara's picture

so as soon as the  tape is automatically mounted in a drive,it is assigned irrspect to the data has been written onto it or not.

Thanks all.

noazara's picture

Time Assigned is when NetBackup first allocates the tape to be used.  It may

or may not contain data.  Use the bpmedialist command to be sure.  If the

column is blank,  the tape is definitely unused and does not have any valid

data on it (i.e.  no data in the image catalog, there may be old, expired

data on the tape that will remain there until it is overwritten