Video Screencast Help

Time Window question

Created: 30 Aug 2013 • Updated: 30 Aug 2013 | 1 comment

We upgraded from BE 2010 to BE 2012 SP2.

Active Alerts are popping up showing that a number of jobs "missed" because there were no storage resources available during the scheduled time window.

In BE 2010, there was a setting in the job schedule to specify a time window, however it appears that that setting is no longer available. Instead, I presume that the time windows is now defined by setting a start time in the schedule, then specifying a number of hours to wait before the job reschedules. Correct?

That said, it appears that the time window settings on the old jobs were carried over to 2012 during the upgrade, yet I cannot find a way to update these except to re-edit each and every job.

Per the old settings, most of the jobs in question are set to start at 8:00 PM and not run after 8:00 AM. The same schedules under 2012 show the jobs scheduled to start at 8:00 PM and then reschedule after 48 hours. Yet I'm getting the "missed" alerts at 8:00 AM each morning, which leads me to believe that the old scheduled items have inaccessible "hidden" attributes.

I guess I just need to bite the bullet and re-schedule all jobs from scratch to ensure that they are set properly.


Operating Systems:

Comments 1 CommentJump to latest comment

pkh's picture

There is no time window parameter in BE 2012  and the reschedule parameter is not the same as the time window parameter.  For the older versions of BE, suppose you have a job which re-occurs every hour, you can use the time window parameter to restrict this job to run only between 9 - 5.  In BE 2012, the re-schedule parameter does not do this restriction.

I think you are right in your assumption.  What you can do is to change the re-schedule parameter to 12 hours, instead of 48 hours, for each of your jobs.  This way it will work like the time window parameter of old.  After 12 hours, your jobs will be re-scheduled.