Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Timeout on NetBackup Job Manager service

Created: 17 Jul 2013 • Updated: 27 Jun 2014 | 8 comments
Michael G Andersen's picture

Hello

We are getting some

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the NetBackup Job Manager service.

in system event log on our Netbackup 7.5.0.5 master server running Windows 2008 R2 SP1 MSCS which correlates with get_string() failed - network read error (10053) in the problems report.

All the Netbackup exe files and folder should be excluded from the anti virus

I already have a case on the getstring issue with Symantec, but thought I would ask on the forum too

Regards

Michael

Operating Systems:

Comments 8 CommentsJump to latest comment

revaroo's picture

Michael, have you tried temporarily turning the antivirus off to double check?

Dyneshia's picture

try increasing the default timeout value from 3000 milliseconds to 6000 millieseconds.

Steps for increasing it are given in the Microsoft article.
http://support.microsoft.com/kb/922918

Michael G Andersen's picture

Yes have had killed the anitvirus processes and was still getting the error

Not sure it is a good idea to raise the timeout for services to a full minute.

Mark_Solutions's picture

It is a very busy system?

It could be that the Master is running out of tcpip ports

A netstat -a will show the state of your ports - if a lot are in a TIMED WAIT state then add a registry key:

Under HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

add a new DWORD named TcpTimedWaitDelay  with a decimal Decimal Value of 30

You can alsoincrese the number of ports available as WIndows 2008 only has 16383 available. You can increase this using:

netsh int ipv4 set dynamicport tcp start=1500 num=63000

from an administrative command prompt - this takes effect immediately, the registry key needs a reboot - set these on both nodes of the cluster

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Michael G Andersen's picture

Assume you mean TIME_WAIT state ? Have about 500 right now of about 1150 connections, guess there will be more connections at night when the big backups run

Have already increased the number of dynamic ports on our master and media servers to 50000

Mark_Solutions's picture

Yes sorry - the default on Windows is 4 minutes - not far off the NetBackup default timeout of 5 minutes!

The registry entry i gave reduces that to 30 seconds to keep the system cleared down quickly so that you dont run out of ports or get unneccesary timeouts.

If you are using advanced disk or de-dupe then, just in case it is waiting for responses from the Media Severs it is also worth adding the following to the Master and all Media Servers:

Unix:

/usr/openv/netbackup/db/config/DPS_PROXYDEFAULTRECVTMO

Windows:

<install path>\veritas\netbackup\db\config\DPS_PROXYDEFAULTRECVTMO

Open it up and enter a value of 800 into it

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Omar Villa's picture

Do u have any logs u can share? Timeouts are always tricky and also considering is windows have u rebooted the box?

Omar Villa

Netbackup Expert

Twiter: @omarvillaNBU

 

Michael G Andersen's picture

The problem has persisted over multiple reboots.

Hoping that Symantec Support find the reason for the get_string timeouts