Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Timeout when trying to connect to SSIM

Created: 16 Oct 2012 | 7 comments

Hi,

I get an error "Time out occurred while trying to connect to the specified host" when trying to access SSIM through the manager console. I'm also unable to access SSIM webpage through web browser. It was working fine earlier.

I tried doing a ping on the server and it works. Logs seem to be coming through to the server as I can see packets on both port 443 and 514 when I did a TCPDump on the ports. Therefore I'm ruling out network issues. I tried restarting SSIM services and a full server restart but it doesn't solves the problem.

Is there anything I missed out that I should be looking at to solve this issue?

BTW, SSIM is installed on the physical server itself, not on any virtual hosts, for example, VMware.

Thanks in advance.

Comments 7 CommentsJump to latest comment

Laurent_c's picture

First step if the WebUI is not working is to either ssh or log on local console.

 

As root, run a "status" command. It will show you a list of process, see if some are down, like the simbdmu.

loftystew's picture

Hi Laurent_c,

Thanks for replying. I ran a "status" command. I did see some of the listed process are down. I ran startservices.sh -all script and got all the process running as shown below. However, I am still unable to access the WebUI or the console manager.

Not sure if this affects, I have added Microosoft jdbc driver 4.0 files recently into the drivers folder and did a chown -R sesuser:ses to it and It was working fine. This issues only occur till few days later. Based on the screenshots shown below, Is the file/folder ownership alright? Did I accidentally change the ownership of the rest of the SSIM folders/files?

Thanks in advance

sg_eugene's picture

if you have access to the console, try to bring the interface down and up again. eg

ifdown eth0, ifup eth0

or else ifconfig eth0 <IP> netmask <subnet> up

 

For my case, I have to issue these commands upon every reboot or config change.

loftystew's picture

Hi sg_eugene,

Thanks for replying. I tried using the provided command to bring down the interface and up again but it still doesn't solve the issue. I also tried another services restart after resetting the interface and it didn't work too.

I checked logs from symantec event agent using agentmgmt.bat. It seems that the agent is also having trouble connecting to the SSIM server.

Laurent_c's picture

the first log file to look at in general is the one from the manager located in :

/opt/Symantec/sesa/logs. Check the manager.log and eventservice.log

sg_eugene's picture

Let's do a try everything method - basically i did all of these steps when troubleshooting my deployment

1) verify network connections - client machine telnet to ssim manager on port 443, 636 as well as 22 (if u use ssh)

2) if using off box agent - agent machine telnet 443, 636 to ssim collector box

3) ssim collector box telnet 443, 636 to agent box

4) ssim manager telnet 443, 636 to collector box

5) make sure that your dns server can resolve ssim's hostname. modify your client host file if needed.

6) confirm your port/duplex settings. every equipment should preferbly be using a static speed/duplex. For myself, I configured client/agent/manager/collector/switch/firewall - basically every device from end to end to be on 100 full. my old config of "auto" on ssim manager gave me loads of problems.

 

 

If everything goes through, it means your firewall/network is ok... next

7) issue a "ifconfig eth0 <ip address> netmask <subnet> up"

8) issue a "ifup eth0"

 

Do not perform any services/machine reboot. try to access from client to manager again. if fail, continue..

9) fire up your browser, go to https://<hostname/IP of manager>/sesa/servlet/Admin?action=stats

10) check for any devices listed in the blacklist and clear them.

 

If still fail, I think it will be better for tech support to read your logs.

Thanks

Avkash K's picture

you can try clearing your local java cache.

Regards,

Avkash K