Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Timeouts and Slow Performance Of SMP 7.1 Asset Screens

Created: 03 Dec 2012 • Updated: 09 Jan 2013 | 2 comments
This issue has been solved. See solution.

Hi Team,

The performance of the Asset screens has never been outstanding however I'm now getting timeouts for many of the screens eg. Home->CI Management->Organizational Types->Location.  

I'm getting "Please Wait" then timeout for this and many other screens as well so I'm not able to do things like add locations, users, get software license reports etc.

I've done some tracing with the help of the DBAs and the DB seems to be working OK.  The following queries execute in well under a second but the SQL stream seems to go on for quite a while and I can't tell when it has finished getting all the info it needs to populate the page.  Also there seems to be a lot of repeated SQL

  DECLARE @TrusteeScope nvarchar(max)  SET @TrusteeScope = '{24678E39-40D8-42E0-A8C1-91F8FFCA99D0},{2E1F478A-4986-4223-9D1E-B5920A63AB41},{582029E2-FC5B-4717-8808-B80D6EF0FD67},{6B77DBD0-578C-4CC6-A5D4-60A99AB9A431},{9C3EB1FF-E09E-4E27-AC68-6B2139873B2F},{B760E9A9-E4DB-404C-A93F-AEA51754AA4F}'   

SELECT   vri.[Guid] AS [_ItemGuid],   vri.[Name],   isnull(vu.Name,'') as 'Manager',   Loc.Address,   Loc.City,   Loc.State,   Loc.Country,   Loc.Zip  FROM      [vRM_Location_Item] AS vri    JOIN vLocation Loc on vri.[Guid] = Loc._ResourceGuid  left outer join ResourceAssociation raUser on raUser.ParentResourceGuid = Loc._ResourceGuid and raUser.ResourceAssociationTypeGuid = 'cac9ea4c-af5e-4c9e-bb62-67ded2cea546'  left outer join vRM_User_Item vu on vu.Guid = raUser.ChildResourceGuid  WHERE   vri.Guid in (select ResourceGuid from ScopeMembership where ScopeCollectionGuid in (select ScopeCollectionGuid from dbo.fnGetTrusteeScopeCollections(@TrusteeScope)))  group by   vri.[Guid], vri.[Name], vu.Name, Loc.Address, Loc.City, Loc.State, Loc.Country, Loc.Zip  order by   [Name]            

Finally there seems to be a lot of this SQL going on:  What does it mean.  A search for "Evt_AeX_Client_Crash_Detection" on the forums didn't return any results.

INSERT INTO dbo.[Evt_AeX_Client_Crash_Detection] ([_ResourceGuid],[Assembly],[Time],[State],[Dump],[Location],[Process],[Duration],[Source],[_eventTime]) VALUES (N'c13d885a-2a89-474b-af82-19e1b42d0e69',N'aexnsagenthostsurrogate32.exe',N'2012-11-30 07:50:08',N'Running',N'C:\Users\Public\Documents\Altiris\Altiris Agent\CrashDumps\aexnsagenthostsurrogate32_SP10845_2012-11-20_06-01-09.dmp',N'Unknown',N'aexnsagent.exe',N'2',N'Altiris Agent',N'2012-12-03 15:38:36.833')
 

Thanks

Mark

Comments 2 CommentsJump to latest comment

abhishek_rane's picture

Hello,

I am able to see 50000 Location resources in my test environment.

It would be helpful if you provide information related to the version of ITMS that you have installed ,Details about NS machine’s system configuration (RAM ,Processor), Type of NS machine(Virtual  or Physical ) and  total number of locations.

I am using ITMS 7.5 where I have not seen this issue.  

Thanks,

~Abhishek

Deep Green's picture

Hi Abhishek,

Thanks for the response.  After many days of debugging and web ex sessions with Symantec backline we found out the the error was due to IIS redirection configuration issues on the application server.  It was simple to fix however extremely difficult to track down because we didn't know where to start looking.

Only parts of the SMP console timeout so it was no obvious the the application server was the issue. Also no changes were applied by our team the configuration of the application server.  The only conclusion that I can draw is that somewhere in the infrastructre a routing or DNS entry was updated that invalidated the existing configuration.  I suspect that we will never be able to determine the cause of the issue.

Again - thanks for offering your assistance.

Best Regards

Mark

SOLUTION