Video Screencast Help

Transaction log backups are not being performed.

Created: 15 Nov 2012 | 3 comments

Hello I need some help in this issue:

In this week BackupExec start to give this message: 

"Database ReportServer is configured to maintain transaction logs. Transaction log backups are not being performed. This will result in the log growing to fill all available disk space. Regular log backups should be scheduled or the database should be changed to the simple recovery mode."

We have the backup job in Full mode and we already change the Databases in "Simple mode recovery" it's something more we have to change in SQL Server ?

Server Specs:

Win2008 64 Bits R2 Enterprise

Backupexec 2010 R3 (V13.0 Rev.5204 64Bits)

 

Thank you.

Comments 3 CommentsJump to latest comment

VJware's picture

Nothing more...If all the SQL databases (atleast the ones selected in the backup job) are changed to a simple recovery model, this message should not appear...

Try recreating the selection list & the backup job..

Lastly, another alternative ~ Verbatim:

HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec for Windows\Backup Exec\Engine\SQL Server\Number of Non-Log Backups Before Warning
The default value is a decimal value of 10
Increasing this value will increase the number of full database backups it will take to display the exception
Setting the value to 0 will disable this exception from ever occurring.  Symantec does not recommend setting this value to 0.

Donald Eady's picture

I would Suggest leaving the SQL database running the Full recovery model and creating a (INC)log backup for SQL. please review the following tech doc 

http://www.symantec.com/docs/TECH126063

 

I hope this posting was helpful

  

Nabil polska's picture

To backup a SQL Server located inside a Virtual Machine (VM), that is not configured for Simple Recovery Mode and to truncate the logs, run standard SQL Agent Full and Log backup through the remote agent installed inside the VM.

If AVVI or Hyper-V backup jobs are still scheduled, these must be scheduled so that they do not interrupt the sequences of SQL Agent Full and Log backup jobs.