Video Screencast Help

Trouble with Automation partition

Created: 24 Sep 2012 • Updated: 05 Oct 2012 | 15 comments
This issue has been solved. See solution.

I'm having trouble getting any new clients to boot into automation correctly.  I've tried updating and re-creating the preboot configuration environments but that didn't help.  I tried running a repair on my NS and that didn't help either.  Clients that already had the automation agent installed on them continue to work fine, it is only new machines.

I get a failed to boot to \boot\bcd message and an error of 0xc000000f

I've tried a couple things in other threads but that didn't seem to help, I can't image these machines in this state... :(  I can get them to boot again by running the fixboot command from a command line via the repair console but as soon as you re-install the automation agent I am right back at the same point.

Comments 15 CommentsJump to latest comment

admobandy's picture

It would seem that this is now only an issue on one of our PC models, the Optiplex 790...  I have tried updating the bios to no avail...

admobandy's picture

Well I finally found some bread crums that took me somewhere.  I noticed on Dell's site that there were WINPE vista drivers for the 790, one of which was a storage device driver.  I added that to the preboot drivers, but I still get the same message when trying to boot to automation... :(

admobandy's picture

Tried some additional WINPE drivers from dell today for storage and still no luck with these Optiplex 790's.

Saeed's picture

Hi Admobandy,

This seems to be a problem with bootloader,  it is definately not a problem with driver as it will give a different error for driver.

I would suggeste you to try and create a new boot image and try booting with it.



If a forum post solves your problem, please flag it as a solution. If you like an article, blog post or download vote it up.

admobandy's picture

I got the preboot environment re-made and now the machine boots fine and just won't boot to automation, before after installing the automation agent it wouldn't boot there-after.  Now I have a 0xc0000098 error for a ifm60x32sys file.  Now I must be missing a driver... :(

ianatkin's picture

Hi, just to confirm what you already have gleaned... the STOP 0xc000000f error in WinPE is because you haven't got the required mass-storage support loaded. The error you are now seeing with  ifm60x32sys is because somehow the NIC load has buggered up.

Check  what NIC support you need in this model, and grab that driver. The device IDs are a great help here to match up what you see in device manager on a machine to what you see in an inf file.

Kind Regards,

Ian Atkin, IT Services, Oxford University, UK

Connect Etiquette: "Mark as Solution" those posts which assist you most in resolving your problem, and give a thumbs up to useful articles and downloads

admobandy's picture

I've got all the drivers needed added to the preboot environment.  What I'm seeing now is that for some reason what I'm adding through the console isn't showing up within bootwiz itself although it shows under the preboot tab within the driver database management page in the console.

When I look at the bootwiz environment manually on the server by running bootwiz it looks like there are files missing from C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\bootwiz\Include\WINPE2\SHARED\DriversDB

It does not match what I see under C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\bootwiz\Platforms\Winpe2\x86\Drivers

The first folder path is the one that I see being used by the preboot environment for WINPE, but the drivers being added through the console are going in the second path there.

admobandy's picture

After doing some more digging, it would seem that I am missing drivers in the following location on the DS C:\Windows\System32\DriverStore\FileRepository

Any way to get these synced up again?

It also looks like the drivers.manifest.txt file is not complete in c:\program files\altiris\altiris agent\agents\deployment\task handler\driverDB

It matches bootwiz exactly and stops after broadcom drivers even though there are many more folders in the driver DB directory.

admobandy's picture

I deleted the drivers.manifest.txt file and opened the database manager in the console to regenerate it, then I re-created the preboot environment and tickled my NS agent so it would kick off bootwiz again.  Bootwiz ran for much launcher that it had been before but bootwiz still shows a truncated driverDB.

admobandy's picture

I removed the DriversDB folder from the WinPE 2.x additional files configuration and re-added c:\program files\altiris\altiris agent\agents\deployment\task handler\driversDB to it and re-generated the preboot environment once more... still get the same ifm60x32.sys 0xc0000098 error... :(

admobandy's picture

So I figured out which driver is causing all that headaches and it's Intel.IFCoEMP-

What is the proper way to remove a driver from the preboot environment?  It doesn't look like this is a needed driver.

admobandy's picture

Got this driver re-moved and recreated my automation environment and I am at least able to boot into automation on my machines again.

admobandy's picture

site server not updating driver folder... :(

admobandy's picture

Ok I think I finally have this figured out.  This is happening on machines where the dell recovery/utilities partition was not removed when it was imaged with our old Novell solution.  I now need to look into removing that partition before getting the automation agent on them... :(

I've added re-partitioning tasks to our re-imaging task in the mean time to work through re-imaging machines that have this problem already.