Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Trouble getting SQL backups to run of over private backup lan

Created: 31 Jan 2013 • Updated: 08 Feb 2013 | 4 comments
This issue has been solved. See solution.

I am having an issue whereby we have the Symantec Netbackup Appliance 5520 configured as Master & Media server, which has connectivity to the production LAN and also the Private backup LAN.  I have configured the backups to use the dedicated private back up network, but on some systems, this does not seem to work correctly and data goes over the production LAN.

Master/Media has a hostname on the production LAN eg nnbumaster 10.10.x.x, which is also registered in DNS and a totally separate IP and hostane for the backup LAN eg nbumaster-bk 192.168.x.x (backup LAN information is configured in host file on master/media to reference host and vice versa, but not registered in DNS).

Policies are configured to backup client client1 IP 10.10.x.x using the backup LAN hostname and IP as specified in the host files eg. client1-bk IP 192.168.x.x.

Flat files windows backups are routing fine using this method, but SQL backup are talking over the production LAN and backing over this LAN, even though host file entries have been configured the same as the other working systems.

Can anyone advise if using the appliance as master & media is supported any are there any issues, since this something new that I am working on, but surely the principles are the same as a non appliance based Netbackup environment.  We are running the latest version of Netbackup 7.5 and could do with guidance on how others may have implemented a totally dedicated private backup network.  Also are there any issues encountered on best practices that need to be followed when doing restore since client1 is the actual hostname, but in terms of the backups images, these are accessible  under the backup LAN hostname client1-bk.

Anyone assistance would be helpful.

 

 

 

 

 

Comments 4 CommentsJump to latest comment

Nicolai's picture

The fact that file systems are using the private backup lan show you have configured the routing correctly. The trouble  is that all database backups are proxy backup and do not behave like file systems. What I think happen is that the SQL server somehow resolves to the DNS name of the production LAN and  uses that LAN for connectivity to the master server.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Marianne's picture

Configuring SQL backups on backup LAN is covered in NBU for SQL Admin Guide . 

See 'About configuration for a multi-interface network connection (multi-NIC)'

Please also check hostnames used in the backup script.

Another helpful TN: http://www.symantec.com/docs/TECH54733 
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Uncle_Bob's picture

Marianne/Nicolai

We have a strange issue whereby the Master/Media(5520Appliance) is working fine on some of the systems configured using hostnames for resolving the backup network names suffixed with -bk, but then on a couple of systems the backup traffic is going over the public interface. Setup is identical to that on the working systems, but BPCD logs show:

On the working system, the connection is being initiated from the master/media server over the backup interface IP and response coming back on the respective backup IP interface off the client.

On the problem system, the connection being initiated from the master/media server over the public IP interface and response coming back on the backup IP interface off the client. Monitoring task manager on windows to  view the network interfaces shows symmetrical traffic graphs. Backup data is being pushed over the public network and acknowledgement requests back to the master over the backup lan interface.

This is problem is quite unique and we have logged a case with Symantec Support who are analysing the support logs and as yet no respone. Not sure if this is down some configuration issues on the appliance or a bug, but why does it work for some systems and not other when confugured using the same process.

At first we though it was the systems with SQL, but we are having the same when doing a flat file backup on the affected systems.  Configuring 5520 appliances to act as a master & media server in one is supported, so not sure what to do next,  apart from wait for a resolution from suppport.

 

Uncle_Bob's picture

Thanks to all who responded, but Symantec Support backline engineers have suggested a fix/workaround based on the following technote: http://www.symantec.com/business/support/index?page=content&id=HOWTO60779&profileURL=https%3A%2F%2Fsymaccount-profile.symantec.com%2FSSO%2Findex.jsp%3FssoID%3D1360359885492iDQ6semh42s35Ec9F7yLTLto59vRd4TAj6a38

They still cannot explain why it worked for some systems, but on others traffic was routed incorrectly over the public interface.

SOLUTION