Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Trying to set up Deployment, getting stuck.

Created: 14 Dec 2012 • Updated: 20 Dec 2012 | 12 comments
This issue has been solved. See solution.

Ok.  First a bit of background so what I am asking makes sense.

We have been on CMS for about 2 years, since the release of 7.0.  I was the one-man install team for our CMS install.  One of the components that I had real trouble with early on was the Deployment solution.   It seemed that the Deployment solution was oriented around large scale mass deployments of the type that my company never does.  I spent quite a bit of time looking for a way to set it up so we could do the one-off type imaging that we usually do on a day-to-day basis and failed completely.  I got so frustrated with it, I ended up simply turning off the PXE server and developing a CD based imaging process using the Bootwiz tool and RDeploy  (I only chose RDeploy because it imaged faster than Ghost).

So 7.1 SP2 MR1 is now our current version and Deployment has been updated a little bit.  My boss REALLY wants us to be using Deployment and has asked me to take a second look at getting it set up so that we can at least do a standard Desktop image with it, in preparation for 7.5, which is supposed to FINALLY give us the real one-off capability that CMS has sorely been lacking.

So here I am, walking through the latest iteration of the Deployment setup guide.  I have the PXE server up and running, it is pushing a windows based PE boot image, and everything is working.  Riiiight up until the PE image finishes it's boot process.  Then...  nothing.  the PC just sits there looking at me.  I have configured "Initial Install" settings, and as far as I can tell the darn thing should boot into WinPE, install an OS, add it to AD into a specific container and then reboot.  But I get...  Nothing.

I suspect I need to add some additional post-boot steps to the WinPE process, but for the life of me I can't figure out HOW to do that!

Also, when I create additional preboot configurations, I can never select them in the PXE configuration menu.  I only ever get one choice, the default winPE config.  (EDIT:  Just fixed this by deleting the default preboot configs entirely.)

Ironically, after the system PXE boots, if I hit F8 I get a menu to select from which has all my configs.  Wierd.

So I'm pretty much stumped.  I feel like I need to be able to edit the WinPE configs (maybe using bootwiz?) but I can't figure out how to do that, or if that is even proper.  Does anyone have a clue here?  I'm lost.

Comments 12 CommentsJump to latest comment

andykn101's picture

Before you try and get initial deployment working I'd try and get a simple WinPE job working.

So I'd set up a Job with the following Tasks:

  1. Reboot to > WinPE
  2. Run script > Command Script > pause
  3. Reboot to: Production.

Run this on a computer with the Symantec Management Agent and Deployment Plug-in.

I think you old PE entries show because they are cached on the PXE server, try rebooting that.

Whenever I design and set up a DS infrastructure I read these useful KB articles:

"DS7.1 Support Quick Start - Setting up and configuring Deployment Solution"

http://www.symantec.com/docs/HOWTO30267

"Deployment Solution 7.x: Image Storage, Replication, & Removal"

http://www.symantec.com/docs/HOWTO21731

And then use this when stuff goes wrong :-)

"Commonly Used Articles for Deployment Solution 7.x (updated November 2012)"

http://www.symantec.com/docs/HOWTO55859

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

SOLUTION
mmooney's picture

Interestingly, in that first doc, on the third page under "5. Create some jobs" -> "For Deploy Jobs"  it notes that after the Reboot to Production phase you should add in a "Run Script on Server" task to make the server wait for a second before running any more tasks.

The problem is that "Run script on Server" type tasks are not available to select as part of a Client job.  Soo...  I guess I just skip that?  Strange...

mmooney's picture

Thanks for the links, I'll check them out.

I actually do have WinPE working.  I can PXE boot a PC and have it boot into WinPE with no problem.  The trouble is what to do AFTER that.  I don't seem to be able to get the Altiris WinPE to do anything.  (Doesn't start loading an image, won't run the OS install, won't do anything after it completes it's startup process.)

Also, yes, I can reboot a PC into Automation as well.  The thing is, I need to be able to image and reimage PCs without relying on the Agent already being installed.  Reimaging with the Agent in place is really only useful if I'm going to upgrade to a new OS or do a mass reimage.  Both of which we don't do either much (upgrade) or at all (mass image).  Mostly we only image one or two-off new blank HD PCs or reimage corrupted and otherwise damaged PCs.  So being able to reimage from the agent, while nice, isn't what I need.

Hopefully those docs you linked will have what I'm looking for.  Thanks!

 

EDIT:  BINGO!  That very first link had exactly what I needed!  That article should be a sticky in this forum, it would have saved me SO MUCH trouble!  Thank you!

Sally5432's picture

actually imaging without the agent being in place is easier than imaging with the agent in place because you get the initial deployment menu options.  You don't need the console at all.  

7.5 is supposed to give that functionality to computers with agent installed, but 7.5 has been delayed.

We are a relatively small environment that uses 7.1 SP2 MR1 for deployment, so you're not alone, post here if you have other questions.

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

mmooney's picture

Wait...  Say that again?  I'm confused.

For us, the reason we never used Deployment was because we got NO menu.  It just pushed out one image and that was our only choice.

Previously we have been using Novell Zenworks' PXE system to push images.  It would boot into it's Linux-based PXE environment and we would be presented with a list of OS images to install onto the target PC  (This is done from the target PC)  We would select the image, walk through a short menu, and it would image the PC and reboot it into the windows minisetup.  Since we swapped from Zenworks (dumping Novell) to Altiris we have wanted to have a similar process in place, but we could never figure out how to replicate that same general process in Altiris Deployment.  Altiris Deployment seemed only to be capable of pushing a single image to a large number of computers, and nothing more.  No menus, no options, nada.  So we dumped it in favor of a custom brewed rDeploy CD.

My understanding was that 7.5 would give us the ability to get a menu during the (non-agent) imaging process so that we could pick from a list of available images.  Are you telling me that this is actually available NOW?

Sally5432's picture

If you don't have the agent on your machine(s), and boot to PXE, if you have initial deployment set up, it will prompt you for which image job to send.  Check settings, deployment, initial deployment. That is where you add which jobs are available once you PXE boot an UNKNOWN machine.  We default to reboot to production (if tech walks away), and then have about 8 image jobs for techs to choose from.

It is one of the best parts of Altiris 7.1 in my opinion.   

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

mmooney's picture

I poked around a bit and found it.  This is exactly what I needed!  I can set up several imaging jobs and just have our tech be able to select from them.  Thanks for pointing that out, I would have completely missed it!  Thanks!

EDIT:  So, what do you do about known machines that need to reimaged?  (used machines returned to stock or machines with OS damage that won't boot, etc.)

Sally5432's picture

You're welcome.  I have jobs set up in the console that techs run quick runs on, first step is boot to pxe, then run image job, then reboot to production.

I'm hoping in 7.5 my techs won't have to be in the console much anymore, but it keeps getting pushed back.

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

mmooney's picture

Ok, now I'm feeling like a dope again.  I hope you don't mind answering a few more questions.

So I've gone through and set up some Initial Deployment jobs to do various things  (One for sysprepping and imaging, another for a basic backup and a few to push images)  I selected all of them as options for Initial Deployment and gave myself a 10 minute window to select an option after which it should just reboot to production.  I've run the Delta Resource Update task and restarted the PXE server services  (just to be sure everything was "in there" and functioning) and I've started testing.

 - Reboot the PC manually and kick it into network boot manually.  Works great.

-  PXE boot and get the F8 menu, works great.

 - Select the bog standard x86WinPE for PXE boot option, boots right up into it.

 - Get the standard Symantec WinPE boot screen, it goes through it's startup phase and the Command window minimizes and then...

NOTHING.  It just sits there with a minimized command prompt window and the standard Symantec background image.  Bringing the window back up shows that it completed it's startup sequence and just ended.  nothing else was launched.

So...  What did I do wrong here? 

Sally5432's picture

This is a new machine never booted to PXE, right?  If it's not, it won't ever see initial deployment options.  If they were ever booted to PXE before, I'd find them in the console, delete them and then restart PXE and try again.

Under PXE server conifg, I have it set that unknown computers boot to my WinPE config, I don't have to hit F8 on those.

 

Here's some troubleshooting info 

http://www.symantec.com/business/support/index?pag...

 

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

mmooney's picture

Ahh..  ok.  No, this is an existing system that I am testing with.  it already has the agent on it.  that probably also explains why I always get the F8 menu.

(So, what the heck am I supposed to do with existing systems that need to be reimaged?)

Interestingly, when I tried to do a "Reboot to Automation" job to make a backup image of it, I ran into the exact same problem.  It simply stalls out after starting WinPE.  So even the Automation part. which SHOULD work on an existing system, doesn't.

EDIT:  Just realized I never turned on the upgrade policy for the Automation partition.  Turned that on and will allow it up upgrade the automation partition and then will try again.

Sally5432's picture

For existing machines " I have jobs set up in the console that techs run quick runs on, first step is boot to pxe, then run image job, then reboot to production."

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.