Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Ugrade from 12.1. to 12.1.2 need more than 2 hours

Created: 08 Feb 2013 • Updated: 08 Feb 2013 | 20 comments
This issue has been solved. See solution.

Dear all,

i'm try to upgrade my SEPM from ver 12.1.1000 to 12.1.2 but it take time to long...even now the proses is still running.

first step i shutdown all symantec services, and running the SEPM setup.

but after 2 hours.....my server stuck in : Manaegement Server Configuration wizard and status is loading.

i'm affraid it's fail........

can you help me........

Discussion Filed Under:

Comments 20 CommentsJump to latest comment

.Brian's picture

Is there a sepm_inst.log at %temp%

Can you post it if so?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

.Brian's picture

If you do a Start >> Run and just type %temp% it should come up

Its the temp location located under the users profile

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

SebastianZ's picture

Was any SEPM replication configured on the Manager?

Is this installation running on the embedded database?

raesinekti@gmail.com's picture

sebastian : no...i didn't use SEPM replication.

need your suggest...can i restrat my server and try to install again ?

SebastianZ's picture

From what the logs reports the installation itself was sucessful:

MSI (c) (FC:CC) [00:33:32:484]: Product: Symantec Endpoint Protection Manager -- Configuration completed successfully.

...what hangs now is the part of the management configuration wizard.

Try running the following:

 C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\bin\upgrade.bat'

raesinekti@gmail.com's picture

i try your step..but nothing to do...

i see the SEPM all ready ....can i login ?

James-x's picture

Hello,

Can you please run collectLog.cmd (default location: C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Tools) and attach the ZIP file it creates (SEPM_Logs.zip).

If that's too large to attach, then please ZIP up and attach the following logs from the ..\Symantec Endpoint Protection Manager\tomcat\logs directory: scm-server-0.log, install_log.err, and install_log.out.

James

The Symantec Endpoint Protection Knowledgebase

Please remember to mark the post which resolved your issue as the solution!

James-x's picture

Thanks for getting those logs. I've found the issue in scm-server-0.log; the SEPM can't connect to the embedded database service.

Caused by: java.sql.SQLException: [Sybase][ODBC Driver][SQL Anywhere]Database server not found
    at ianywhere.ml.jdbcodbc.jdbc3.IDriver.makeODBCConnection(Native Method)

Can you please open Services and verify that you see the Symantec Embedded Database service. If it's there, what is its start type? It should be Automatic. Is the service started?

James

The Symantec Endpoint Protection Knowledgebase

Please remember to mark the post which resolved your issue as the solution!

raesinekti@gmail.com's picture

i can't see the Symantec embedded database service james.....

only :

1. symantec endpoint manager status stop..try to start but can't

2. SEP web server status started

3. Symantec managenent client status started

James-x's picture

It looks like the upgrade removed and never correctly put back the Symantec Embedded Dtabase service. That explains the errors in scm-server-0.log.

Can you try repairing the Symantec Endpoint Protection Manager in Add or Remove Programs, run Upgrade.bat again, and let me know the results?

James

The Symantec Endpoint Protection Knowledgebase

Please remember to mark the post which resolved your issue as the solution!

James-x's picture

I'm sorry to hear that.

I'm afraid that at this point, your quickest option is to probably restore the SEPM from a backup and then attempt the upgrade again.

Do you have database and recovery backup from before the upgrade?

James

The Symantec Endpoint Protection Knowledgebase

Please remember to mark the post which resolved your issue as the solution!

raesinekti@gmail.com's picture

Yup I have.....
James I need your suggest.......ithink i'll remove the sepm and maybe the windows 2003 either...
I prefer that the fresh OS more better than the old one
Question is....if I install the new Sepm 12.1.2.....any issue if restore the database from the older version ?

Need your suggest james

James-x's picture

Hello,

The new OS needs to have the same hostname and IP address as the old in order for this to work.

You will need your database backup file (C:\Program Files\Symantec\Symantec Endpoint Protection Manager\data\backup) and database backup file (C:\Program Files\Symantec\Symantec Endpoint Protection Manager\tomcat\..\Server Private Key Backup\recovery_2012-01-16-10-35-00.zip) before you begin.

Your steps will be:

- Install SEPM 12.1 RU2. Use the recovery file when going through Management Server Configuration Wizard.

- Moving your database backup to .\data\backup and using the Database Backup and Restore Wizard to restore the database.

- Run Upgrade.bat after database restores

- Go through Management Server Configuration Wizard again.

Let me know if you have any questions.

James

The Symantec Endpoint Protection Knowledgebase

Please remember to mark the post which resolved your issue as the solution!

SOLUTION
raesinekti@gmail.com's picture

I see....you mean I can't install 12.1.2 with 12.1 ru2 database.....

Tks for the info......I'll try ...... soon