Video Screencast Help

unable to add FSA target

Created: 24 Jul 2012 • Updated: 18 Nov 2012 | 17 comments
ElGringo's picture
This issue has been solved. See solution.


I am unable to add folder or FSA on windows 2003 (SP2) File Server.

See screenshot attached.

I am running EV 10.0.1.

the VSA is also a member of the local admin group and have Full access right on the folder.

I use hidden share as volume (E$ in my case)

I am not running VAC from a remote server

Any help will be very appreciated !

Comments 17 CommentsJump to latest comment

AmolB's picture

Post the error message or attach screenshot.

ElGringo's picture

see the error message attached.

Mohawk Marvin's picture

Have a look at this:

RahulG's picture

Remove the File server from the targets, and try adding it again using FQDN name i.e Servername.your domainn I had faced simlar issue , and later came to I had entered the short name of the file server instead of FQDN.

ElGringo's picture


OK. I will try to check the name resolution.

I'll tried to create a fake ADS using  "echo fakeads > \\myfilesrv\Volume\Share:myads" which failed

TypoProne's picture

Can you please update this posting? If you are still having an issue let us know and we can try to fix it. It seems like some of the suggestions provided to you could have helped you to resolve it . If so please flag them as the solution. If you resolved it yourself... please update the posting to reflect its resolution and flag it accoridingly. Doing so helps to direct peoples assistance to where it is most needed.

Many thanks.


TypoProne's picture

Also if you are still having the issue can you please attach the file of the dtrace (please do not paste it into the forum) of the MMC while reproducing this issue for review.

Thanks again.

Kamil Tatar's picture


I have to ask, Enterprise Vault Admin User is local admin on your target server ?


ElGringo's picture


Yes, the VSA has appropriate permissions

According to Setting Up File System Archiving Guide on p38 :

Local administrator rights on the file server

Full control on any share that is configured as a target volume

Jeff Shotton's picture

How about we take this back to basics a little? You failed to create an ADS stream on the remote file server. You should be able to do this (I can)

Can you confirm, using the VSA from the EV server,  you have successfully:

1) Opened the remote share

2) Accessed a file on it

3) Created a brand new file on it (at the same level that the ADS would be created for the archivepoint)



Jeff Shotton

Principal Consultant

Adept-tec Ltd

Website: here

RahulG's picture

Did you tried the removing the File server and adding it again using FQDN  as I suggested beore ?

ManishN's picture


I think from my experience this seems to be the timezone key issue, but difficult to suggest as the dtrace is not attached, if you coud upload the dtrace then it would be easy to suggest.



ElGringo's picture


Yes ManishN, I tried.

I am able to write and read datas thru the UNC path so it seems that TimeZone is not an issue.

I used support tool to create an Alternate Data Stream on the file server. This tool use the same API as EV uses.

I was able to create the ADS only with DOMAIN\Administrator account but not the VSA (I also tried to add the VSA to BUILTIN Administrator group and DOMAIN\Administrator group ...)

I also notice that creating an Alternate Data Stream using command line is not successfull with the VSA. I get this error message : "The system cannot find the specified file"

It seems that my issue is related to a Microsoft stuff 

The customer has gone. I'll try to send you the log using a private message if it's OK for you.

This is driving me crazy !

ManishN's picture

ok, np

You can send me the logs and little brief about your issue.



TypoProne's picture

I think I have seen behavior like this when the directory structure did not provide access. I seem to recall this being an issue on a NetApp when the CIFS was nested in a nonCIFS .... or something like that.

If this is just a windows box... you can probably follow the access denial via ProcessMon (using the filemon portion of it to see where you get blocked. THe good news is you know it is just a permissions issue and not an EV issue as the Administrator account is not having the same problems. With the right tool or proper review of the log... you should be able to isolate the fialure and correct it.


ElGringo's picture


After some more tests it sems that iPanema appliances might be linked to our issue. Does anyone use EV FSA with iPanema appliance ?

Many thanks !

ElGringo's picture

Yes, iPanema was the root cause of my issue. iPanema developped a fix. And finally, things seems OK now.