Video Screencast Help

Unable to assign send as permission on system mailbox

Created: 07 Oct 2012 • Updated: 03 Nov 2012 | 3 comments
gparker's picture
This issue has been solved. See solution.

Hi, I'm setting up EV 10 with Exchange 2010. I created the EV service account and its mailbox as well as the EV system mailbox. When I run the Add-Adpermission -Identity <system mailbox> -User <domain\EV service account> -AccessRights ExtendedRight -ExtendedRights "send as" command, it comes back with "<system mailbox> wasn't found. Please make sure you've typed it in correctly". I tried entering the system mailbox's address several different ways, but no luck.

Please help.


Comments 3 CommentsJump to latest comment

TonySterling's picture

Someone else had a similar issue, their solution was this:

Open Active Directory users and computers.

Find the mailbox you want to add the user to, right click, properties, then security tab, advanced button, Permission tab, then at the bottom if the box isn't checked, check the box for "Include inheritable permissions from this objects parent."

Click ok through the warnings, apply, and exit out of those properties and then test again.

Worth a shot.

gparker's picture

Hi Tony, that check box was already checked. Thanks anyway.


gparker's picture

Hi, I think I just got it to work:- With the "-Identity" switch, I've been entering the mailbox that's associated with the system mailbox account, i.e., the ev system mailbox is evsystem@company.local. But I just tried the switch with the AD account name that's associated with the system mailbox and it seems to have worked!