Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to attach previous Dedupe store on new install of BUE

Created: 20 Aug 2014 • Updated: 20 Aug 2014 | 5 comments
This issue has been solved. See solution.

Story so far:

I had a total loss of my BUE server. VM completley lost. I ran up a fresh one (Server 2012 R2, BUE 2014) and attempted to reattach my old Dedupe store. When processing, I get the following error message "Unable to Create the deduplication disk. An error occured while creating deduplication storage. See the following link for additional information: http://support.symantec.com/umi/v-287-40960-39685".

When I upgraded to BUE 2014 (clean install on new VM) from BUE 2012, I had the same problem. At the time I was able to write off the previous backups, and start afresh. However, when I lost my BUE box, I also lost 2 DB servers, and a file server as well as another 2 application servers that I would reall really like to get back.

 

Trouble Shooting so far;

  • Ensured dedupe service account (svc_bue_dedup) has local admin, and log on as service rights.
  • Ensured all BUE service accounts have local admin rights to server.
  • Disabled UAC
  • No AV installed on VM yet.
  • Taken ownership of the entier drive holding the dedupe folder, granted said ownership to local admins group.
  • Checked there is no other software installed on server (clompltley fresh VM with brand new install of bue)
  • Copied the entire 700gb dedupe folder to a fresh disk and tried to attach from there. Same error message.
  • Tried to create a new dedupe folder on a freshly formatted disk, same error.
  • No postgres or other sql services
  • Same domain as previous server
  • All accounts are identical to before the crash. Service account names and passwords have not changed.

 

Last time I saw this issue, I had to formatt the target drive and reinstall BUE altogether. That is not an option at the moment. I will try a fresh install shortly, but any suggestions would be appreciated.

Operating Systems:

Comments 5 CommentsJump to latest comment

pkh's picture

First of all, using a VM as a media server and accessing real devices is not supported.  Next, due to the processing requirements of dedup, the use of a virtualised media server is not recommended.

Firman's picture

Thanks for the response, but that isnt very helpful.

Are you able to provide any further assistance, as a physical machine is not an option at the moment.

For the sake of learning from this issue, what would you recomend doing if this was a physical machine?

pkh's picture

For disaster recovery of the dedup folder, you should have taken a backup of the shadow copy component. So far, I have not come across any way of just attaching to an existing dedup folder.

Firman's picture

When creating a new dedupe storage target, there is an option in the setup to attach an existing dedupe store.

Firman's picture

As suspected, the fact that the media server was vitrualised, had nothing to do with the issue.

When I did the initial fresh install, I did not select the deduplication components, and instead added them later. For some reason, when they were added later, they did not install properly. I did a fresh build since posting my original comment and installed all the required components at the time of install, and was then able to attach my old de duplication store. If anything, this points to an issue with the installer, not with runnign the software on a virtualised platform.

I am a bit annoyed at the response I recived from PKH as it was not helpful in the slightest. It may not be recomended, but there are technically no issues in setting up a VM installing the enviroment onto that server, and pointing all storage to iSCSI targets attached through the windows iSCSI infrustructure. Also, the fact that the software is hosted on a VM had absolutley nothing to do with the issue I was expiriencing, as outlined by the resolution.

SOLUTION