Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to backup server shares

Created: 17 Oct 2013 • Updated: 17 Oct 2013 | 4 comments

Recently we replaced a network administrator so I don't have access to the System Logon Account and am unable to delete and re-assign the System Logon Account (working with tech support via phone for this part). I did however manage to give all appropriate rights to a different account and can successfully backup all needed resourses (minus the shares) on servers that run the RAWS agent. The problem comes in here, I have multiple SQL machines and for some reason the agent frequently tries to access our SQL databases throwing errors and making my DBA's angry. To get around this we just add them as file servers and backup the log/transaction files from the SQL servers shares. The account that works just fine for all my RAWS is used to also back up these shares. However whenever I test the credentials or attempt to backup these resources I get a credential logon failure. I am able to successfully navigate to the directory browse/copy/write all that good stuff using the supplied credentials from the Media Server. Basically I have no idea why it won't backup (nor does my current phone tech support, we spent 4+ hrs and got nowhere). Has someone else run into this or can throw me a bone? The only thing I can think is that maybe for some reason Backup Exec is still trying to use the old System Logon Account credentials instead of the supplied new ones?

Much appreciated,

 

Jared

 

Please note I am running Backup Exec 2012 SP2

Operating Systems:

Comments 4 CommentsJump to latest comment

Jaydeep S's picture

Jared, you would not be able to backup the SQL transaction log files the way you want to while the SQL database is online. The only possible option is to perform a SQL database backup using the SQL agent or making your SQL admins to schedule maintainance plans and create a dump file which can be then backed up by Backup Exec.

Network's picture

Thanks for the tip Jaydeep, problem still remains though that I'm totally unable to authenticate to even get access to the shares (some are not on SQL boxes). Any hints on what I can do to get it to actually authenticate? This whole thing was working 1 week ago so I know it's possible. Thanks again for the tip Jay.

lmosla's picture

If there is an antiviris program running make sure you have excluded all the database files from the scan and on the media server set exclusions for the Backup Exec processes.  

What were the initial errors that caused the workaround?  I'm curious if the problem is related to the share issue.

Steve_'s picture

If you go to tools> Audit logs, you may be able to see what the error is.

I recently fixed this same problem with our SQL server not backing up due to the credentials provided (Even though it was backing up previously with these credentials).

I found that there was a service which had randomly stopped on the SQL server (I think it was a service which was to do with the backup exec remote agent so look for a service like that). But it was just a matter of logging into the server and starting the service.

If this doesn't work try going tools>install agents, and see if there are any agent installs which you think should be pushed to this server.

*Please mark as solution if this has resolved your query*