Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to configure appha on vmguest after installation. Admin page over port 5634 not accessible

Created: 15 Sep 2012 • Updated: 01 Oct 2012 | 9 comments
This issue has been solved. See solution.

Hi,

I am evaluating application HA and got stuck with

The installation was successful xprtld is running

Port 5634 is open and I can connect from Vcenter server over http://vmguest:5634

However I am not able to see appha details from Vcenter Server vm guest tab

It says: Unable to retrieve status of vmware guest machine.

On checking 14152 and 14153 ports are not listening on VM guest. What is the service I need to confgure or start to get this port on listen mode in the vmguest?

Could somebody please help

Thanks in advance

Hari

Comments 9 CommentsJump to latest comment

Soumya Sakha Tripathy's picture

Please verify that VMware tools is installed (latest) and running in the VM.

That might be one of the reason of the tab not appearing.

 

Also, you can check the log?

Click "view log" button/link, which appears at the bottom of the ApplicationHA tab when you select the VM.

That might give some clue.

You may like to share that here as well.

Hello Nair's picture

VWware tools are installed and are running. The tab appears but it displays the message "Unable to retrieve status of vmware guest machine." .

1) There it asks me to check whether the ports5634, 14152 and 14153 ports are blocked.

2) Verify whether appha services are running

and there is a retry button.

First of all, there is no firewall.

When I logon to the guest I can see 5634 port is listening. But not 14152 and 14153. What is the process which open 14152 and 14153 ? Is xprtld expected to do that

What are the services to be running on a appha client /vmguest ?

 

 

 

Soumya Sakha Tripathy's picture

The ports 14152 & 14153 are used by processes running in ApplicationHA Console - not the guest system.

In VM guest, Veritas storage foundation messaging service (xprtld) should be running - which listens on port 5634.

 

Also, can you check whether invoking the following URL directly from browser works fine (it will ask for the user name / password of the VM guest)?

https://<guest_IP>:5634/vcs/admin/application_heal...

If that works, then there is no problem with the guest and the issue will be more around the communication via AppHA Console.

 

Also, did you check the log from "View log" link?

Hello Nair's picture

Thanks for that clarification.

Regarding the access, I am not able to access the path you have mentioned over port 5634. ie application_health.html

However I am able to access http://<guest ip>:5634/admin/htdocs/cs_config.htm which display Veritas Operations Manager.

If I proceed with defaults and Next buttons ie. Server Setting > Db setting> Analytics Setting and Configure, It gives an error that VRTSsfmcs package is not installed.

 

 

 

Prasanna Kulkarni's picture

Thanks Hari. It could be namespace issue. Please check that the line "namespaces vcs=/opt/VRTSvcs/portal" exists in xprtld configuration file /etc/opt/VRTSsfmh/xprtld.conf.

If this line does not exist, please add this line (without quotes) to the end of this file and restart xprtld using "/etc/init.d/xprtld stop" and "/etc/init.d/xprtld start".

Let me know if it helps.

 

--

regards,

Prasanna

SOLUTION
Hello Nair's picture

Hi Prasanna,

Thanks. Your solution worked.  After updating  xprtld.conf, I was able to get the Application HA tab working and ADMIN  url port 5634 working too.

In fact, I had to apply the patch mentioned in https://sort.symantec.com/patch/detail/5925 too.

Now I have another issue which I posted in https://www-secure.symantec.com/connect/forums/nat...

Regards

Hari

Prasanna Kulkarni's picture

Thanks Hari. Good to know that your issue is resolved.

Can you mark that reply as solution and close this thread?