Video Screencast Help

Unable to connect to the selected NetBackup host ""

Created: 26 Mar 2014 • Updated: 01 Apr 2014 | 11 comments
This issue has been solved. See solution.

Hi All,

Windows 2000 (Service Pack 4)
X86 Family 6 Model 10 Sepping
NBU Master server version 6.5.6

NetBackup console is not opening, giving below error.

Unable to connect to the selected NetBackup host ""

1. Make sure the user "admin" has privileges on the host.

2. Make sure the local host is......

and some more points, can be find in attached screen shot.

Below is what I tried.....

1) Restart the services, Console opens...but after some time getting same error.
2) During bpdown, failed to stop some demon. Killed them manually.
3) Not able to stop bpdbm, getting permission issue.
4) Name resolution ok (nslookup, reverse nslookup)
5) Checked in registery, name is defined accurately.
6) Put the entry in HOSTS file.

Please assist if anyone has faced such issue earlier.

I know that 6.5.6 is EOL, but cant upgrade to 7.x as server is windows2000. But still the things are in progress to upgrade the hardware first then the NBU.

Operating Systems:

Comments 11 CommentsJump to latest comment

Will Restore's picture

Been more than a few years ago, we had Dell server running Windows 2000 and same trouble ("Unable to connect to the selected NetBackup host ...") when NIC teaming was implemented.  It should have worked but was always trouble.  Anyway that was ancient history.  If you have NIC teaming, try disabling it and see if that helps. 

Will Restore -- where there is a Will there is a way

VerJD's picture

@ Vickie,

Wow, you're right, that system definitely needs a hardware refresh and an upgrade to NetBackup 7.x. wink

Anyway, when services are restarted... you definitely want all of them to stop before you restart them again, especially "Adaptive Server Anywhere - VERITAS_NB - ASA Database service" (NB_dbsrv) and "NetBackup Database Manager" (bpdbm).

- Do you have the exact error when you try to stop bpdbm, or when you run this command?

install_path\Veritas\NetBackup\bin\bpdbm -terminate

Otherwise, it sounds like the NetBackup services are running under a different user account than the account you logged in with, or your account doesn't have full admin privileges... 

- Are the NetBackup services running under Local System or a domain admin account?

(Use this technote as reference for what services should be running on a NB 6.5 master: TECH57455)

As an alternative, if you cannot get all of the services to restart...

- Can you reboot the server, log in under the NetBackup service account, to get all the services to start up properly together, and then open the admin console?

JD | NetBackup Technical Support

Vickie's picture

@ JD

There is no error during bpdbm terminate. I restarted the ASA, and it worked from services window.

I logged in with admin rights on the server. The services are running on local system account.

I rebooted the server, when server came up I open the console....ran a backup but it gives error like below.

Lack of connectivity detected between media server and master server. 

3/27/2014 3:56:33 AM - requesting resource masterserver-storage-unit
3/27/2014 3:56:33 AM - requesting resource
3/27/2014 3:56:33 AM - requesting resource masterserver.NBU_POLICY.MAXJOBS.nbupol
3/27/2014 3:56:33 AM - awaiting resource masterserver-storage-unit Reason: Media server is currently not connected to master server, Media Server: masterserver,
     Robot Number: 0, Robot Type: TLD, Media ID: N/A, Drive Name: N/A,
     Volume Pool: DAILY, Storage Unit: masterserver-storage-unit, Drive Scan Host: N/A
client process aborted(50)

Marianne's picture

It is always difficult to assist with troubleshooting when you cannot share real hostnames.

Something has changed at OS level as far as hostname is concerned. If you open cmd and issue 'hostname' command, what do you see?

Compare above output with 'nbemmcmd -listhosts -verbose' and 'nbemmcmd -getemmserver' output.

Also create bprd and bpdbm log folders and stop/start NBU with bpdown and bpup. Check these 2 logs to see how hostname is compared with NBU configured hostnames.

PS: You REALLY need to migrate to supported OS and NBU version. Even Microsoft has dropped support for W2000 some years ago.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Vickie's picture

Hi Marianne,

D:\VERITAS\NetBackup\bin\admincmd>nbemmcmd -getemmserver
NBEMMCMD, Version:6.5.6
Unable to get the local EMM server for the following reason: "cannot connect on socket"

C:\Documents and Settings\admin_rsingh18>hostname

D:\VERITAS\NetBackup\bin\admincmd>nbemmcmd -listhosts -verbose
NBEMMCMD, Version:6.5.6
The following hosts were found:
        MachineName = "MASTERSERVER"
        FQName = ""
        MachineDescription = ""
        MachineNbuType = server (6)
        ClusterName = ""
        MachineName = "MASTERSERVER"
        FQName = ""
        GlobalDriveSeed = "VEND:#.:PROD:#.:IDX"
        LocalDriveSeed = ""
        MachineDescription = ""
        MachineFlags = 0x4
        MachineNbuType = master (3)
        MachineState = not active (6)
        NetBackupVersion = (656000)
        OperatingSystem = windows (11)
        ScanAbility = 0
Command completed successfully.

Some of the error I found from old BPRD and BPDBM logs. And latest one are attached.

Error from BPRD logs.

00:39:20.649 [71900.76740] <16> bkarfiles: Unable to write progress log </D/VERITAS/NetBackup/Logs/user_ops/dbext/logs/vxbsa.1395905957.76716.6708.prog.pcb_std> on client MASTERSERVER.XXX.COM. Policy=Catalog-Pol Sched=Weekly

BPDBM logs error I found,

01:03:35.587 [10636.71648] <16> do_online_nbdb_backup: Error backing up files in D:\VERITAS\NetBackupDB\staging
01:03:35.884 [10636.71648] <16> exec_catalog_backup: exec_asa_database_backup() failed (2)
02:34:40.431 [69784.71088] <16> process_request: requestor MASTERSERVER is not a valid server for IMAGE request 9101:03:35.884 [10636.71648] 
04:11:45.790 [73944.73396] <16> delete_expired_backups: OVsystem(D:\VERITAS\NetBackup\bin\admincmd\nbdelete.exe -allvolumes -jobid 53974) failed (128)
04:15:41.634 [70444.71076] <16> close_handle: Terminating child process before client closed connection because parent bpdbm process died

032714_bprd.txt 7.08 KB
032714_bpdbm.txt 8.01 KB
Vickie's picture

Now after running backup again, getting below error in detailed logs.

cannot send mail because BPCD on MASTERSERVER.XXX.COM exited with status 23: socket read failed
Vickie's picture

I found one major difference, I believe that could be root cause.

bpclntcmd -pn  (gives output as MASTERSERVER)
bpclntcmd -self (gives output fqdn MASTERSERVER.XXX.COM)

D:\VERITAS\NetBackup\bin\admincmd>bpclntcmd -self
gethostname() returned: MASTERSERVER.XXX.COM

D:\VERITAS\NetBackup\bin\admincmd>bpclntcmd -pn
expecting response from server MASTERSERVER 

Please assist if this can cause the issue, then how can I resolve this ?

VerJD's picture


bpclntcmd -pn, is telling you that your registry SERVER entry is correct. (MASTERSERVER)
bpclntcmd -self, is telling you that your client information is different. (MASTERSERVER.XXX.COM)

  • NOTE 1: NetBackup is case sensitive, so the entries should match what's reported in 'nbemmcmd -listhosts'

Please check your registry Client_Name entry is using MASTERSERVER, and your hosts file entry matches the 'nbemmcmd -listhosts -verbose' output:

        MachineName = "MASTERSERVER"
        FQName = ""

So the hosts file entry should look something like this:     MASTERSERVER

After making changes, be sure to restart NetBackup services. ('bpdown -f -v' ⇒ 'bpps' ⇒ 'bpup -f -v')

  • NOTE 2: Make sure your client name in the policy also matches, since it looked like it was all lower case FQDN in the detailed status, if I remember correctly.

(Also Reference: Explanation of bpclntcmd options and recommended troubleshooting when the commands return errors. - TECH50198)

JD | NetBackup Technical Support

Marianne's picture

You need to find out what has changed at OS level to make hostname show up as fqdn.

In the meantime, add IP address with both shortname and fqdn in master's hosts file, the stop and restart NBU with bpdown and bpup. That should resolve the hostname lookup issue.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Vickie's picture

Thanks all for your support.

Actually the issue was with name, I just modify and make all name entries same to same wherever I found the server name I just changed it identically.

By doing this the issue resolved and now the backup running fine.

Thanks once again. :-)

VerJD's picture

You're most welcome Vickie, glad to assist. Thanks for bringing your question to us and marking the solution.

Have a great week! (seriously, no April Fools about it) wink

JD | NetBackup Technical Support