Video Screencast Help

Unable to create an "apply system configuration" which joins a domain.

Created: 26 Jul 2012 • Updated: 03 Aug 2012 | 3 comments
This issue has been solved. See solution.

Hello.

 

Im quite new to Altiris, as i took over for one who just left for another job.
So far I have been able to read up what i need to get stuff up and gooing. 
Delivering programs, imaging a windows 7 image, and making a solution to get them out quick have not been a problem.

 

But getting the deployment job to join the computer into a domain .. Man im getting frustrated =)

Under the task Apply system configuration, i have set up under computer configuration:
Computer name %serialnumber%   <-- This part works great as computers get their correct name from the bios.

Domain: mydomain.no

User name: mydomain\domainadm name <- Tried with the domain\name and just the domain administrator name. Neither works. I can manually enter the domain so i know both the name and passwords are correct.
password xxxx
confirm passord xxxx

 

When i run the task on a test computer i have here, i get "failed - code 1" everytime.

Ive even tried putting a random name into the tab where i now have %serialnumber% just to test, and then it boots the computer and the new name is there. But not the domain.

I have also tried to fully turn of the UAC on the test computer, to see if some windows 7 permissions were making it harder. Did not help either.

So, anyone got a good tip ?

Comments 3 CommentsJump to latest comment

mclemson's picture

Is the Depoyment Plug-in installed on the computer where you are running the task?  It's a deployment task so you will need the deployment plug-in.

Regarding the login, can you manually use it to join a computer to the domain?  Can you use it to change OUs in the domain?  If you can't join the domain manually with this credential, it won't work with the task.

Did you specify an OU?  Or only the domain?  If you have not specified a domain, be sure to enter one.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

SteffenBorge's picture

Hello Mclemson!

 

Yes on all questions actually =)

 

But however, i ended up finding a way around it.
I deleted the entire sequence and did as follows.

Run Depoly image
Run reboot to production
Run Activate Administrator Account

Run Apply system configuration <-- Now ONLY with %serialnumber% event. so it only changes the computers name and then restarts

Run Apply System configuration <-- Now ONLY with the domain name, and domain user + password. Left organizational unit empty. This WORKS and the computer restarts, and boots up in the domain, and AD have gotten it into its default Computers folder.

Run send Basic inventory.

 

Now, making one apply system configuration for each of the steps, and dumbing it down completely worked like a charm.
Before we migrated to Win7 from XP, I could run one apply system configuration which changed the name to %serialnumber%, and entered the domain and the specified OU at the same time.

Odd.
But it works.

I etached screenies of it, so that you can more easily see what I mean, and hopefully this might help some others with the same problem. =)

 

Manly hugs and kisses from Norway.
Steffen Borge

 

apply system configuration #1.jpg apply system configuration #2.jpg The entire Job.jpg
SOLUTION
nnewcomer's picture

I had the same issue. I was able to get the computer name to change, but unable to join it to the domain. When I created 2 tasks (1 to rename and 1 to join domain), it worked.

 

Thank You.

Ned Newcomer

Network Administrator

City of Peoria, Arizona 623-773-7255 (Work)

Ned.Newcomer@peoriaaz.gov