Video Screencast Help

Unable to create new group PGP Universal Server 3.1.2

Created: 17 May 2011 • Updated: 02 Jun 2011 | 11 comments
This issue has been solved. See solution.

I am trying to create a new group on our PGP Universal Server 3.1.2 (build 9) and am running into problems.    I've tried following this link (https://pgp.custhelp.com/app/answers/detail/a_id/2017/~/how-to%3A-create-a-group-in-pgp-universal-server-3.0) yet when I get to the part where I'm supposed to click "Save" I get a webpage error alert on the bottom left status bar in my browser. When you click on it for more details it shows "YAHOO is undefined"... I've tried different web browsers and different PCs and keep getting the same error... need to be able to recitfy this so I can create a new group.

I've attached a screenshot of the error, please see file.

Any suggestions are very much appreciated as I've been waiting over 3 days to hear back from Symantec tech support on this case I've created...

Browsers tried: IE 6, IE 7, Google Chrome 11

Comments 11 CommentsJump to latest comment

Sarah Mays's picture

I haven't seen that error before. Is this a new universal server install or an upgraded one?

I notice that universal server gets a little 'weird' if it runs out of the hard drive space, so i'd check to see if that's an issue. There are two ways to check on hard drive space, if you have email alerts being sent the daily email will say how much HD space is being used, the other way is to ssh to the server.

[root@pgptestserver ~]# df -kh
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             7.7G  3.8G  3.6G  52% /
/dev/sda1              99M   17M   78M  18% /boot
tmpfs                 506M  8.0K  506M   1% /dev/shm
 

Support is extremely backlogged, PGP *really* needs to hire more people ASAP :)

FPguru77's picture

Hi Sarah, 

Thanks for replying. This is a new setup that... I'm not familiar w/using ssh to connect to the server but I'll deffinetly dig into that and see if I can tell what the disk space usage is like. Finally got an email reply from Symantec saying that they were "researching".... 

Sarah Mays's picture

Are there any errors in the PGP Administration logs?

Usually in these situations support will ask you to turn on debug logging on the server, run the problem process again and then send them logs.

https://pgp.custhelp.com/app/answers/detail/a_id/1...

FPguru77's picture

There are some errors actually... looking like pointing to a java issue on the console? Here's a paste of what I'm seeing... unfortunetly the date on this error is old... back in April which is when the server was turned up. I'm going to check into your link about logs and run through the process you've suggested. Thanks so much for your suggestions :) Still very new to this setup and have admin training scheduled for June

 

Unhandled exception in OMC: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
EXCEPTION STACK TRACE:
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        at java.util.ArrayList.RangeCheck(ArrayList.java:547)
        at java.util.ArrayList.get(ArrayList.java:322)
        at com.pgp.omc.AdminWDEDiskInformationScreen.renderWRDTButton(AdminWDEDiskInformationScreen.java:402)
        at com.pgp.omc.AdminWDEDiskInformationScreen.render(AdminWDEDiskInformationScreen.java:147)
        at com.pgp.omc.AdminWDEDiskInformationScreen.doEvent(AdminWDEDiskInformationScreen.java:90)
        at com.pgp.omc.AdminControllerServlet.dispatchEvent(AdminControllerServlet.java:644)
        at com.pgp.omc.AdminControllerServlet.doGet(AdminControllerServlet.java:426)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:627)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:775)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:704)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:897)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
        at java.lang.Thread.run(Thread.java:619)

Andreas Zengel's picture

Hello,

 

in this case please do contact Symantec Technical Support for help with this issue.

Contact details can be found here: http://www.symantec.com/business/support/contact_t...

 

Regards
.andreas

FPguru77's picture

I've already opened a case with them going on a week ago now... no response other then "researching"... gotta say not really impressed, thanks for your suggestions though 

paulhen's picture

Is your PGP Universal server installed on physical or virtual hardware? How much memory does it have? (Minimum supports memory size is 4GB and minimum support disk size is 50GB.) Depending on how the server is being used, the minimum usable amounts may be a bit less or much larger. Personally, I expect issues any time PGPU has less than 1 GB memory (even with 0 load).

It may be worth restarting services or rebooting the server.

 Governments keep a lot of secrets from their people . . . Why aren't the people in return allowed to keep secrets from the government? --Philip Zimmerman, Der Spiegel

FPguru77's picture

 

Hello paulhen

Our PGP Universal server is in a different building/state then where I am physically located... personally have never seen the physical roduct.  I've asked for specifics from admins inhouse and been advised that it is a "pizza box"if you will... it's own console labeled PGP... it's not a software suite that was loaded on a traditional windows server. 

I followed this link (http://www.symantec.com/business/support/index?page=content&id=TECH149673) from Sarah's suggestions previously about checking RAM and disk space. 

I was able to just now get in via SSH and have used her sample command of df -kh and have the info listed for me!! :)

 

[root@servername ~]# df -kh
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2              47G  3.2G   41G   8% /
/dev/sda1              99M   17M   78M  18% /boot
tmpfs                1014M  8.0K 1014M   1% /dev/shm

I'm not sure how to find out the ram... the info above looks to be just disk space info.

I restarted the services while on the phone with tech support last Friday... no change. Tech ended up advising he would need a few days to research and would get back to me... im guessing they dont count weekends so if I don't hear back by end of day tomorrow I'll try calling in again.

I have not tried restarting the whole server yet... as I'm not sure what the down time would cause for clients... perhaps I should restart it during our maint window tonight... any suggestions on what a restart does for clients? Right now we only have external disk encryption setup in a consumer policy... I can't imagine it would cause a lot of issues... but hate going in blind :)

 

 

 

Have suggestions on 

Sarah Mays's picture

For a WDE only deployment, server downtime doesn't effect existing clients. During the outage, you wont be able to enroll new users or encrypt new disks (WDRT)

FYI, I'm using PGP universal server on a test VM with a 10GB HD and 1GB of ram and do not see the group issue you have, i suspect it's not a resource issue causing this error for you.

FPguru77's picture

Just following up for those interested.... got ahold of a great tech that went the extra mile and found an article in support pages that was simliar to my issue yet not exact... figured it was worth a try to implement the fix. We SSH'd to the console and he ran some commands that in basic terms rebuilt the web portion of the console. The thought process is when the server was upgraded in April some script didn't finish completely and hosed up portions of the GUI.

Here is the link the tech used to fix the issue:

http://clientui-kb.symantec.com/kb/index?page=cont...

SOLUTION