Video Screencast Help

Unable to delete old tape drive - Still in use

Created: 19 Jun 2012 | 15 comments

Hello,

We are running Backup Exec 2012 on SBS 2008 box. We were not having any issues other than running out of space on our LTO2 drive, so we have replaced that with an LTO4 drive (straight swap, using exisitng cables). I have added the new drive into Backup Exec with it can see and use but I can't removed the old drive from the 'All Storage' window. It brings up the following message:

 

"[Drive Name] is currently in use by a job. Please wait intil all jobs have finished before you delete it."

 

If I right click and choose details, it shows no jobs attached to this drive. Any ideas how I can get rid of the drive?

Comments 15 CommentsJump to latest comment

CraigV's picture

Hi,

 

Right-click the server name in the Device tab & choose the option to place it offline. Make sure this places your devices offline too.

Once done, try deleting the drive.

Alternatively, run the Device Configuration Wizard and select the option to delete old entries.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Alastair79's picture

Thanks for the reply.

Backup Exec SBS 2012 does not have a device tab but under the storage tab I can right click the old drive and see the option to set offline, however this is grayed out. The most I can do is is to disable and/or pause, but even if I do both of these it still says active and will not allow me to delete the drive.

Backup Exec 2012 doesn't appear to have 'Device Configuration Wizard' anymore, you do get the 'Configure Storage' but that is for upgrading drives and adding new devices and does not have a remove device section.

I just need to get the drive to stop thinking it active when its not, frustrating.

CraigV's picture

...then consider logging a call with Symantec. They will assist you in deleting this from the BEDB. DON'T go poking around in the BEDB yourself though...

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Larry Fine's picture

this sounds similar, but I don't think it is a resolution for you

http://www.symantec.com/docs/TECH183028

If you find this is a solution for the thread, please mark it as such.

Biker_Dude's picture

There may be a pending alert tied to the LTO2 tape drive that was never acknowledged.  Go to the Home page and view the alerts section in the lower left hand corner.  It may only show the last 12 hours of alerts, so drop down the menu and change it to All...to show all the alerts.  Look for any alerts requesting action, i.e. insert media, overwrite media, remove media, etc...  If you find any, then acknowledge any of these alerts that are currently targeted to the LTO2 drive no longer present.  This should allow you to delete the drive.

If you don't find any, then double check there are no pending jobs still attempting to use the drive.  If this does not pan out, then exit the UI, restart the BE services, start the UI, and try deleting the drive.

If none of these suggestions work, then please open a call with our Technical Support Department.

 

Colin Weaver's picture

Hi All

Whilst investigating the Deduplication Folder issue with the same condition that was documented in TECH183028 above we realized that the condition also affects other types of storage devices.

As such we adjusted the text in TECH183028 to indicate this (Note: the text refresh might take 24 hours to appear on public version of article.)

At this current time we do not have a workaround for the condition however we are working on a fix.

 

 

Lankan's picture

Hi!

Something new about this one?
We got a deduplication folder that's marked as active and prevent a couple of jobs.
As mentioned before i'm unable to delete the device for recreation.

//Johan

gdh12bike's picture

Has this issue been fixed?  I'm having the same problem..

Simon B.'s picture

Does anyone know what the workaround was that obviously was in TECH183028 a few months ago?

PMCS GmbH & Co. KG - Consulting und Support für BE/NBU/EV und andere Symantec Produkte.
Please take the time and mark this post as solution if it solved your problem - thanks!

dbiddle's picture

I second that comment!

We don't have support any longer so I can't call support to have them fix the problem. Workaround details would be nice. In my case, I deleted an old tape library and the magazine/slots were deleted but not the main device. Now I can't use it at all. I was just trying to switch the drivers to use the Symantec drivers instead.

KlausJ's picture

I'd also like to see a complete list of fixes and known issues with BE2012. I'm amazed that this software was ever released. It's ripped of many features found in many previous versions and filled with tons of bugs instead...

dbiddle's picture

Since upgrading to BE2012, I've had nothing but problems. System State's fail to backup, failed file backups because of access denied when all the permissions are fine for the service account... BE2012 is just buggy and difficult.

Wes Miller's picture

Run “”tapeinst.exe” in the root of your BackupExec directory.

Check “Use Symantec tape drivers for all support devices”
Check “Delete entries for tape devices that are unavailable, removed, or turned off”
Check “Use Plug and Play Drivers”

FYI -> USB DEVICES ARE NOT SUPPORTTED

Click and next your way through the rest then finish. This worked for me.

This is for the known issue that removing a tape drive physically or changing it and the tape drive still appears in BE. This also covers the cannot delete because the drive is in use as well.

It is not necessary to edit the DB unless this doesn’t work. NOT LIKELY.

tapeinst.jpg
CraigV's picture

...same with this Wes! Started nearly a year ago with no resolution!

Also not sure where you're directing your information at...thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

KlausJ's picture

I have a client where it was needed to edit the database directly.

I'm still amazed over the number of bugs and features removed in the 2012 version. I wonder why it was needed to change what already worked...