Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Unable to delete shopping service

Created: 05 Jun 2012 • Updated: 15 Nov 2012 | 8 comments
This issue has been solved. See solution.

Hi all!

Are about to remove/delete the file archive server from my EVsite. The site contains two servers, one Exchange archive and the file that is to be removed.

I have succeded to delete/stop all service except the shopping service on the file archive server, also have removed the file archive and the vault store.

When I try to delete the shopping service I get this - see attached file. Any suggestios? thanks!

Comments 8 CommentsJump to latest comment

Tmarques's picture

First the shopping service needs to be stopped and then deleted. If it fails to stop use task manager and stop the shopping services process.

You can also checking the location of the shopping service data if there is any data located in the folder. The default path for the shooping service data is c:\program files (x86)\enterprise vault\shopping delete that data and try again.

Or alternatively but is a last resort is you could remove the service from SQL in the enterprise vault directory database. ShoppingServiceEntryID table

Cheers

 

Wayne Humphrey's picture

 

If you removing the server I would do the following:

Remove all index locations from IndexRootPathEntryId

Remove index service from IndexingServiceEntry

Remove computer from ComputerEntry

Ameen's picture

I had the same experience, it seems SQL still have the Shopping location/service entry present. I dont have any idea why its like that but I feel its a bug kind of thing. I was cleaning this entries by opening the tables.

Hope this help, please always make a backup of SQL DB before deleting entries by opening tables.

Denis Kattithara's picture

http://www.symantec.com/business/support/index?page=content&id=TECH71206

Denis John Kattithara

Partner Assist Services

Symantec Corporation 

ianG's picture

Ran into this recently, and had to do as the technote Denis listed

 

ShoppingCanDelete column, in ShoppingServiceEntry table, in EnterpriseVaultDirectory. Change it from a 0 to a 1, for the service to delete.

 

Also, I believe I had to clear out its shopping directory of all subfolders - I just cut and pasted them elsewhere. They werent all empty, but hadnt been touched in >6 months.

JesusWept3's picture

you dont even need to go that far, i mean end of the day, any items that havent been restored to a users mailbox or deleted items for OWA isn't going to matter much now as you're deleting the shopping service altogether

Rob.Wilcox's picture

hmmm I wonder WHY that database column is 0... preventing the delete from happening.

Krister's picture

This is Solved! It was a missunderstanding between me and the SQL admin. After cleaning up in SQL it was possible to delete this.

 

Have now upgraded to 10.0.2

SOLUTION