Video Screencast Help

Unable to deploy ITMS 7.1 SP2 Symantec Management Agent

Created: 27 Aug 2012 • Updated: 27 Aug 2012 | 6 comments

We are currently in the process of upgrading an off-site from 6.9 to 7.1 SP2.  We have successfully upgraded another off-site and our HQ with no issues.  The error that appears in the management console is  "Failed to run the Symantec Management Agent install service on {0}."  Also, when looking in the Altiris logs on the NS box, we also see the error  "Failed to run eXpress Client Istall Service on %computername%  Error:Failed to start the Service Console Manager on %computername%  Error:80070020"  In addition to the above error messages, the workstations have the "AltirisAgentInstSvc.exe" file downloaded but the AltirisAgentInstSvc.log is never created and the Altiris Agent Installer Service is not created either.  We have tried deploying the agent, via the console, using our service account(which works in both HQ and our other off-site) and a domain admin account with no success.  Also, we have tried deploying the agent using the "closest package server' option and without the option with no success either. 

Any help is appreciated.

Comments 6 CommentsJump to latest comment

Viswa123's picture

Hi mcos,

       Various factors may cause this issue like site server settings,date and time of client machine,windows security settings and so on.

With regards,

Viswanath Sampath

Thanks & Regards,

Viswanath Sampath

MineshP's picture

... And the prize for the most generic answer gos to...?!

I am also having exactly the same issue MCOS1979 - did you find the cause?

Anyone able to assist??

Many thanks

mcos1979's picture

Haven't found an issue yet.  We ended up using psexec to install the altiris 7.1 agent just to get the site up and running.

rldupriest's picture

I encountered issues on 08 R2 servers where the agent would not upgrade from 7.1SP2 to a hotfix version of the SMA.  We discovered after many failures were the older agent would uninstall but the new agent failed to upgrade.  Left behind was the Agentinstallerservice. 

We found after much searching that it was related to the Application Experience service being disabled. 

I know this might be left field but I didn't see anyone else throwing out ideas.

jellsworth's picture

I know this is an old thread...but have we figured out what the "Failed to run the Symantec Management Agent install service on {0}." is all about?

If I figure anything out I'll post it.