Video Screencast Help

Unable to deploy SSR 3013 with Management Platform

Created: 08 Oct 2013 | 2 comments


I'm trialling SSR 2013 with the Management Platform for automated deployment and configuration. I have successfully installed the Managment Platform on Windows Server 2008 R2 (x64) and deployed the Management Agent to a Windows 7 (x64) and a Windows Server 2008 R2 (x64) machines as well as the SSR Agent Plugin. However when I try and deploy the SSR 2013 application it fail with a status of "Run Failed" on the agent.

I've registered the diagnostics plugin and can see the agent log file has the following entries.

source='CoNetworkTransport(258)' module='AeXNetComms.dll' process='AeXNSAgent.exe' 
Invalid data received in HTTP response. Expected 5042 bytes, received 0 (-2147024883)
source='AeXNetworkTransport' module='AeXNetComms.dll' process='AeXNSAgent.exe'
Post to 'http://*****/Altiris/ClientTaskServer/Register.aspx?resourceGuid=5618fcf9-d7da-4326-a9ef-90cab3915983&lastResort=true' failed: Invalid data received in HTTP response. Expected 5042 bytes, received 0 (-2147024883)
source='Client Task Agent' module='client task agent.dll' process='AeXNSAgent.exe'
Attempting to register using "http://*****/Altiris/ClientTaskServer/Register.aspx?resourceGuid=5618fcf9-d7da-4326-a9ef-90cab3915983&lastResort=true"
Operating Systems:

Comments 2 CommentsJump to latest comment

Andreas Horlacher's picture

If the Symantec Management Agent and the SSR 2013 Plugin both deploy, you're getting communication. Check the integrity & existence of the SSR 2013 installer software package.

Open SIM. It will show your installed products on the initial screen. You should see 'Symantec System Recovery 2013 Installer' in the list, with 11.0.1 as the version. If you don't see this, you will need to install it by selecting the 'Install New Products' link above. If you do see it, highlight it and choose 'repair'.

Do this and try again.

Andreas Horlacher

Please mark 'solved' when issue is resolved

choppa's picture

In SIM I had installed 'Symantec System Recovery 2013 Installer x64-x86 SP1', I have repaired the installation through SIM but still got the same error on the agent.

I had to uninstall the agent and run tnhrough the installation again to get this to install.