Video Screencast Help

unable to deport: VxVM vxdg ERROR V-5-1-584 Disk group: Some volumes in the disk group are in use

Created: 05 Sep 2012 • Updated: 05 Sep 2012 | 5 comments
This issue has been solved. See solution.

hi all,

i am getting this error:

VxVM vxdg ERROR V-5-1-584 Disk group : Some volumes in the disk group are in use

none of the volumes are mounted. even after vol stop all the volume in the diskgroup. it still failed to deport with the same error. any idea how to fix this without a reboot?


Redhat version is 5.8

thanks inadvance.



Comments 5 CommentsJump to latest comment

Gaurav Sangamnerkar's picture


that could be a typical problem with linux ..  could u see if any process is holding the volume

# fuser /dev/vx/dsk/<diskgroup>/<volume>

if any process is holding it, you may try to kill the process & then see if dg can be deported cleanly ..


PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.

IdaWong's picture

Hi Gaurav,

Appreciate for the quick reply. unfortunately, fuser didn't report anything. some sort of lock on the volumes? 

any other idea?



Dev Roy's picture

Hello Ida,

# vxprint -g <diskgroup> -m <volume> | grep devopen

If the above command returns "devopen=on" then the volume is still in an active state in the kernel, although it is probably not showing up as mounted when  the df -k command is run.

You may need to reboot the server in order to fix the issue.



Consulting Storage Foundation, VCS, VVR and CVM/CFS on Unix. If this post has helped you, please "Vote" or "Mark as Solution" as appropriate.

Leed.Engineer's picture

I think in such cases with the current platform , the only way is to reboot the host.