Video Screencast Help

Unable to do vxdiskunsetup after destroying cvm DG

Created: 22 Jun 2013 | 6 comments
nitj's picture

Hi Guys,

  I am guys I am getting error while I try vxdiskunsetup after destroying CVM diskgroup and removing vcs SG.

  1. I had tried to clear the keys as well, but did not work that too.

  2. Disk is unprotected from SAN end.

  3. Not able to write label and perform dd as well.

 

 VxVM vxdisk ERROR V-5-1-531 Device "disk": destroy failed:
        Disk write failure
VxVM vxdiskunsetup ERROR V-5-2-5052 "disk": Disk destroy failed.

 

  Any urgent help would be appreciated so much.

 

Thanks.

Operating Systems:

Comments 6 CommentsJump to latest comment

rsharma1's picture

did the clearing of fencing keys work successfully? can you confirm vxfenadm -s (or -g) <disk_path> does not list any fence keys on this now?

nitj's picture

Yeah there are no keys anymore. I cleared all the keys.

rsharma1's picture

ok..have you tried 'vxdiskunsetup -C' option already?

rsharma1's picture

it seems the problem could be at the array level -since dd is also failing (without any fencing keys on the disk). Is this disk write enabled? Do you see any relevant messages in /var/adm/messages while trying to dd ?

nitj's picture

No there are no errors as such. Disks seems to unprotected as seen in inq.