Video Screencast Help

Unable to expand a mailbox in Archive Explorer (Version 7)

Created: 30 Mar 2009 • Updated: 23 Nov 2012 | 9 comments
This issue has been solved. See solution.

Hello!

We are facing a strange problem with one of the mailboxes in EV. We are unable to expand the Archive in the Archive Explorer.

We tried rebuilding index for this archive, but that did not help. This archive is a structured archive.

Please assist as we need to fix this and user needs to be able to expand his archive in archive explorer. Though if we use the search page, then we are able to see items filed in it. (This is not a shared Archive)

Please assist.

Thanks

Comments 9 CommentsJump to latest comment

MichelZ's picture

Was this working before and stopped working for this User?

Paul Grimshaw's picture

1. Goto the VAC and find the archive for this particular user
2. Double clisk on the archive
3. Select properties tab
4. Copy the archiveID
5. Open SQL Query and run the following command:-
Use EnterpriseVaultDirectory
select * from archivefolderview where archiveveid = 'insertarchiveidfromstep4here'

What you should see is the folder structure for that particular archive. Do you see this?

If so then look at the ParentFolderRootIdentity field. Does this marry up? It should look something like this for example if you had a folder called Folder1 underneath the inbox:-

RootIdentity    FolderName                      ParentRootfolderidentity
30                 Top Of Information Store    NULL
31                  Inbox                                30
32                  Folder1                             31

etc etc. I made the numbers up but you get the jist. Folders under Inbox should point to the value Inbox in ParentRootIdentity column and so on and so forth.

EV Backline Technical Support Engineer APJ Region

rathoreshakti's picture

Hi Guys,

thanks for the inputs, we are not getting any error messages. It's just we are unable to expand it.

We checked the SQL & and we are also able to view the folder list using tree view feature (http://evserver/enterprisevault/TreeviewXML.asp?ArchiveID=********Archive&Version=1), so we are sure that the folder structure is there.

One strange thing though, I am now able to expand that archive in Archive Explorer, but if i grant access to some other user, and try to view the Vault in that users Archive explorer, i get the same thing, it doesn't let me expand the vault.

I have rebuilded the index twice and it was successfull both the times, but it still does not resolve the issue, and this thing has worked before.

Paul Grimshaw's picture

You say that you are now able to view the folder structure without doing anything.
 
Sounds permission based to me.

Try running a sync but with Folder hierarchy and permissions selected
do a refresh in AE by right clicking and selecting refresh

Does folder structure sjow up now?

You can view permissions on a users archive and all folders by using the permissionbrowser.exe GUI based app which you will be able to find in your enterprise vault direcory on vault server

EV Backline Technical Support Engineer APJ Region

rathoreshakti's picture

Yes, it worked once, but after I removed myself from the vault of this vault and then added it back, it stopped working.

Now we are again where we started from, Now even I can't expand the folders in Archive Explorer.

with regards to permissionbrowser.exe, is this tool available in Version 7.0. I couldn't find it in the EV directory.

Is there anything else that we could try or do we go with the final option, i.e. export the data, create a new vault, and import data into it?

MichelZ's picture

I would delete the IE cache, too.
Is there anything in IE which could lead to believe that there is a JavaScript error?

Cheers
Michel

MichelZ's picture

That's rather odd.

Sorry, I'm out of ideas, and I would suggest that you open a case with Symantec!

Cheers
Michel

SOLUTION