Video Screencast Help

Unable to install Altiris agent on Win 7 64bit machine

Created: 19 Apr 2013 • Updated: 19 Apr 2013 | 9 comments
shrishail.jivani's picture

Hello,

I am not able to install Altiris agent on Win 7 64bit machine, it's throwing the "Installed failed.Error Message: Failed to run action:InstallCoreAgentDll" error.

Please let me know any have faced this kind of error in NS7.1 Environment

 

Regards,

Shrishail.jivani

Operating Systems:

Comments 9 CommentsJump to latest comment

W007's picture

Hello,

Please make Sure UAC should be disable, let me try manually via IE URL.

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

shrishail.jivani's picture

Thanks for reply. I tried all these links, but didn't work. I am unable to remove Altiris folder from registry under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris.

Also i opened case with symantec, but they didn't resolve it. Symantec people asked me to contact Microsoft to delete reg keys from Registry.

Regards,

Shrishail.Jivani

W007's picture

When you try to delete registry entry do you have received error ?

could you please provide screen shot

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

cleber's picture

I was getting similar error in some machines when trying to install the agent manually . What I did to solve the problem was this. (found here https://www-secure.symantec.com/connect/blogs/unin...)

Use the AeXAgentUtil.exe located at C:\Program Files\Altiris\Altiris Agent\AeXAgentUtil.exe

I run the following commands

AeXAgentUtil.exe /DeleteDevices - Deletes known Altiris legacy device drivers.
AeXAgentUtil.exe /UninstallAgents - Deletes all registered agents.
AeXAgentUtil.exe /Clean - Attempts to completely remove the Agent. It will attempt to detect the relevant version and remove all files and registry entries.

Then I deleted Altiris registry entry at HKEY_LOCAL_MACHINE -> SOFTWARE -> Altiris

Also I noticed some problems with machines where the command line bellow was used to install the agent.

aexnsc.exe –s –a ns=”server.altiris.com” nsweb=”http://server.altiris.com/Altiris” /s

instead of this

aexnsc.exe /install /ns=server.altiris.com /nsweb=”http://server.altiris.com/Altiris”
or aexnsc.exe /install /ns=server.altiris.com ( I used this to install the agent again without errors)

sorry about my english

consoleadmin's picture

I am not sure but if you can try to delete the registry key in Safe Mode may be it can delete.

Try and confirm.

Thanks.

ajpaisley's picture

I think the issue may be that "Use Sharing Wizard (Recommended") is enabled. The agent will not install either though the Symantec Managent web site or the command line install.