Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to launch Java Based SEPM console on windows Server 2008 R2

Created: 13 Dec 2012 | 35 comments

Hi,

I am unable to launch the Java based SEPM console on Windows Server 2008 R2. Webconsole SEPM is fine. While launching the same by installing Java 6 Update 26, the same is being installed but the login page is not coming. Again it prompts to the webpage from where it asks for the installation of Java .

 

Can anybody please help me to fix this as there is a requirement to launch this program as a virtual application once it's installed.

 

Regards,

Sabyasachi

 

 

 

Comments 35 CommentsJump to latest comment

pete_4u2002's picture

is there higher version of Java update installed? if yes , can you uninstall and check?

Sabya_Dash's picture

Hi,

Earlier Java 7 was installed, however I have uninstalled the same but no luck.

 

Regards,

Sabyasachi

pete_4u2002's picture

hope there are no traces of Java 7 .

can yo check from any other machine if you are able to use the java based console?

Rafeeq's picture

try disaling enhanced security in windows IE and add SEPM to the trusted sites list.

AravindKM's picture

Try by disabling UAC

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

Sabya_Dash's picture

I have removed the traces of Java 7 from Registry and program files. The same is launched from other machines as well.

Regards,

Sabyasachi

Sabya_Dash's picture

UAC is already disabled .

 enhanced security is at lowest level.

Still it's returning to the same page.

Regards,

Sabyasachi

Mithun Sanghavi's picture

Hello,

Could you please delete the SEPM Webconsole Shotcut Icon from the Desktop and try launching it from IE again?

Also try clearing Java cache - 

To clear the Java cache

  1. Click Start > Control Panel.
  2. Double-click Java.
  3. On the General tab, under Temporary Internet Files, click Settings.
  4. Click Delete Files.
  5. Make sure all boxes are checked, and click OK.
  6. Click OK to close the dialog boxes.

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

AravindKM's picture

Try this as well

configure the Java console to not use a proxy:

  1. On the Windows taskbar, click Start > Settings > Control Panel.
  2. In the Control Panel, double-click Java.
  3. In the Java Control Panel, on the General tab, click Network Settings.
  4. In the Network Settings dialog box, click Direct Connection.
  5. Click OK.
  6. In the Java Control Panel, click OK.

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

Ashish-Sharma's picture

check this Article also

Intermittent problems loading Remote Java Console

http://www.symantec.com/docs/TECH163714

Thanks In Advance

Ashish Sharma

 

 

Sabya_Dash's picture

Hi Mithun/Aravind,

 

The steps mentioned by you have already been tried but the result is the same.

Regards,

Sabyasachi

AravindKM's picture

Is there any other bowser in your server other that IE? If yes try by making IE as default browser..

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

Sabya_Dash's picture

Mozilla Firefox is there in the server.Even if IE is the default one. Still the same is not working on any of the browser.

Regards,

Sabyasachi

AravindKM's picture

Did you try by rebooting this server?

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

AravindKM's picture

Try this as well

 

Go to start - Control Panel -
Java
- open java control panel
- general tab
- temporary internet files > settings
- tick temporary files on my computer
- click ok
- apply

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

Sabya_Dash's picture

Hi Aravind,

Above mentioned steps have already been carried out, but no luck.

Regards,

Sabyasachi

AravindKM's picture

Which is the version of java you have in SEPM server?

Try by installing the same version in this server and try...

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

Sabya_Dash's picture

It's Java 6 update 26. It's getting installed but unable to launch the console and asking for installing it again.

Regards,

Sabyasachi

AravindKM's picture

Can you try by upgrading installer version?

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

Ashish-Sharma's picture

Hi,

Try to install Java 6 Update 31 version and check it's working or not ?

Thanks In Advance

Ashish Sharma

 

 

SMLatCST's picture

"Thumbs Up" to Rafeeq.

Assuming we are talking about the remote java console here (and you're not experiencing problems on the SEPM itself), instead of installing the remote java console, it is possible to just download the java app and run it.  If you want to try this, then take a look at the below article, and just jump to step 3:

http://www.symantec.com/docs/TECH105179

Incidentally, can you confirm what version of the SEPM you are currently running, and if you have removed any older version of the remote SEPM console that might be installed?

Sabya_Dash's picture

We are currently having SEPM 12.1 RU1. It's not about the Java Heap Size adjustment as this is working on other systems as well.

There is no earlier version of remote SEPM console installed.

I know we can use the webconsole application on the server itself. But the intention is that we need to publish the remote java based SEPM console for the users as a virtual application., for which the application to be installed in the Server .

Regards,

Sabyasachi

 

SMLatCST's picture

I'm not suggesting it is a Java heap size issue, but the article provides steps on how to download and run the remote SEPM console as a java app, rather than installing it.  I was thinking maybe you'd want try that out to see if it makes a difference.

Sabya_Dash's picture

Yes, I can consider your point. Here download and installation of Java is not a problem. Issue is that even after Java is installed on the server again it's redirected to the same page and asking for download the same.

One thing I noticed that  it's showing only the "download" option instead of "Download and Login" while accessing the url of SEPM.

Regards,

Sabyasachi

SMLatCST's picture

Just to clarify, my suggestion is not to re-download Java itself, but rather the java app that serves as the remote console.

If you are certain that there is no config setting in your browser preventing it from detecting that Java is installed and enabled, then you may try downloading the Java App from another machine.  What you should get is a file called "JnlpServlet.jnlp" which contains all the details for the remote java console.  You could then try copying this to the win2k8 server in question and running it.

Note that this file can be edited in a text editor if you're curious as to what is in it.

Sabya_Dash's picture

I could not find the file in a working machine. I think about browser preventing it from detecting that Java is installed and enabled. You are correct.

The only difference I found between these servers where the same is working as IE8 and where it's not working it's IE9

Compared both the security setting and make the adjustment with the one from working server but issue still persists.

Regards,

Sabyasachi

Ashish-Sharma's picture

HI,

Try to login different User profile and check it's working or not.

SEPM 12.1 RU1 are supported IE9.

System Requirements for Symantec Endpoint Protection and Network Access Control 12.1 Release Update 1 (RU1)

 

Article:TECH174720  |  Created: 2011-11-17  |  Updated: 2012-09-24  |  Article URL http://www.symantec.com/docs/TECH174720

 

Thanks In Advance

Ashish Sharma

 

 

SMLatCST's picture

Also, another one worth reviewing is the below article, which seems to more accurately describe the behaviour you're seeing:

http://www.symantec.com/docs/TECH105251

Sabya_Dash's picture

@SMLatCST - After making the changes as mentioned in the link. Still the issue persists. This is the issue mentioned by you i am encountering.

Ashish-Sharma's picture

Hi Sabya,

Do you have try login different user ID ?

Thanks In Advance

Ashish Sharma

 

 

Sabya_Dash's picture

Yes I have tried with multiple ids but it's the same. Usually while launching the url , download and login option should come. However here it is download only.

Please refer the screenshot attached.

Regards,

Sabyasachi

1.jpg 2.jpg
Ashish-Sharma's picture

hi,

Try to Install IE 8 Version and checked ...

Thanks In Advance

Ashish Sharma

 

 

SMLatCST's picture

Can you confirm what settings are applied to your "Trusted Sites"?  Is is possible that the security level has been raised above the Windows defaults, which is then preventing this from working?

You could try administratively lowering the security level of the "Trusted Sites" to the lowest for testing purposes (if not managed by GPO).