Video Screencast Help

Unable to list accounts in "domain2". A domain controller for "domain2" could not be found.

Created: 16 Apr 2013 | 8 comments


As per the title of this message, thats what I get when I try and administer some users.

True, the issue may be an AD one, but AD checks out OK. I wonder if anyone can help check if Vault is set right?

We run Vault 10 on 2008 R2.

Our domain structure is as follows.

Domain (parent)

    Domain1 (Vault exists in this domain)



Domains 1,2 and 3 are all regional domains. We have DCs for each of these domains in the site where Vault resides.

I know there are various ways to force vault to look at one DC or GC... I know at some point a consultant has looked at this. I don't believe it is set... but not sure how many places you can set it.

I know right clicking AD in the VAC you can force it to a GC, but i don't know if there is anything else I can check.

Also, if anyone has any DC suggestions to check then that would be ace.



Operating Systems:

Comments 8 CommentsJump to latest comment

James Slack's picture

To add to this, I just logged on to the console of the server as a "Domain2" user. That worked fine, exactlty as expected.

So the Vault server CAN contact the DC for Domain2.

Not sure why I cant administer users then... must be config in Vault right?

James Slack's picture

Thanks for this JW. I have finally got round to implementing this but will have to wait till next week for testing as this was to fix a problem for our Austrailian users.

Pretty funny. I have been working in IT for 19 years now and this is the first time I have had to use LMHOSTS! Not exactly user friendly is it!!

Thanks for the link, will post results and example back if it works.


JesusWept3's picture

Really? Never used the hosts file?! That's weird! But fingers crossed it'll work!

James Slack's picture

I have used the HOSTS file many times, but never the LMHOSTS one!

I don't think it has worked however... I though this was about a different issue I have with a user in Australia but reading my OP, I see it was not.

I tested this after doing the LMHOSTS file, nbtstat -R and -c to check it went in (it did).

I then went to add permissions to a user in the VAC, selected a different domain to the server (lets say DOMAIN2) and got the original error message I mentioned in this call.

Just trying a reboot...

James Slack's picture

Sadly same deal after a reboot.

To confirm where I get this.

In VAC, go to Archives, Exchange Mailbox, Open user...

Permissions, Add Windows Users and Groups

Pick "Domain2" from the dropdown list.

Get a window popup saying "Unable to list accounts in DOMAIN2. A domain controller for DOMAIN2 could not be found....

The root domain "DOMAIN" works fine. The domain the server is in "DOMAIN1" works fine, but DOMAIN2 and DOMAIN3 do this.

While this is not world ending stuff as I can type it in manually, I would like to figure it out in case it has any other implications that I am not aware of yet.

JesusWept3's picture

It was formatted correctly yeah? It's really really fragile, like with the amount of spaces, if there's one too few spaces then it fails

James Slack's picture

How can I test?

I think it is right as you can run it with a switch and get the results and I see a bunch of stuff to do with what I put in.

The 1st time I did it, I got it wrong. It had to be 20 characerts, with the \ being on 16... when I had that wrong, nothing came up when I ran the checks.

I will double check and post the details here.