Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Unable to open ALtiris Console

Created: 06 Feb 2013 • Updated: 08 Feb 2013 | 1 comment

Hi there,

im unable to open the Altiris Console on the server after he changed Altiris Administrator password.
 
We are getting a lot of errors in the Application Log related to ASP.Net
 
Log Name:      Application
Source:        ASP.NET 2.0.50727.0
Date:          2/5/2013 12:25:03 PM
Event ID:      1310
Task Category: Web Event
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      Altiris
Description:
Event code: 3008
Event message: A configuration error has occurred.
Event time: 2/5/2013 12:25:03 PM
Event time (UTC): 2/5/2013 4:25:03 AM
Event ID: bd13418fc61d44a7bc0645e231f7b02b
Event sequence: 1
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/ROOT/Altiris/TaskManagement/CTAgent-362-130045119028633828
    Trust level: Full
    Application Virtual Path: /Altiris/TaskManagement/CTAgent
    Application Path: D:\TaskManagement\CTAgentWeb\
    Machine name: ALTIRIS
 
Process information:
    Process ID: 2424
    Process name: w3wp.exe
    Account name: IIS APPPOOL\Classic .NET AppPool
 
Exception information:
    Exception type: ConfigurationErrorsException
    Exception message: An error occurred executing the configuration section handler for system.web/identity.
 
Request information:
    Request URL: http://altiris.ums.edu.my/Altiris/TaskManagement/CTAgent/GetClientTaskServers.aspx?resourceGuid=81a15b08-a25c-426a-a319-19516bae575e&shares=1 
    Request path: /Altiris/TaskManagement/CTAgent/GetClientTaskServers.aspx
    User host address: 10.10.2.29
    User: 
    Is authenticated: False
    Authentication Type: 
    Thread account name: IIS APPPOOL\Classic .NET AppPool
 
Thread information:
    Thread ID: 28
    Thread account name: IIS APPPOOL\Classic .NET AppPool
    Is impersonating: False
    Stack trace:    at System.Web.HttpRuntime.FirstRequestInit(HttpContext context)
   at System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
 
 
Custom event details:
Event Xml:
<Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ASP.NET 2.0.50727.0" />
    <EventID Qualifiers="32768">1310</EventID>
    <Level>3</Level>
    <Task>3</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-02-05T04:25:03.000000000Z" />
    <EventRecordID>19364</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Altiris</Computer>
    <Security />
  </System>
  <EventData>
    <Data>3008</Data>
    <Data>A configuration error has occurred.</Data>
    <Data>2/5/2013 12:25:03 PM</Data>
    <Data>2/5/2013 4:25:03 AM</Data>
    <Data>bd13418fc61d44a7bc0645e231f7b02b</Data>
    <Data>1</Data>
    <Data>1</Data>
    <Data>0</Data>
    <Data>/LM/W3SVC/1/ROOT/Altiris/TaskManagement/CTAgent-362-130045119028633828</Data>
    <Data>Full</Data>
    <Data>/Altiris/TaskManagement/CTAgent</Data>
    <Data>D:\TaskManagement\CTAgentWeb\</Data>
    <Data>ALTIRIS</Data>
    <Data>
    </Data>
    <Data>2424</Data>
    <Data>w3wp.exe</Data>
    <Data>IIS APPPOOL\Classic .NET AppPool</Data>
    <Data>ConfigurationErrorsException</Data>
    <Data>An error occurred executing the configuration section handler for system.web/identity.</Data>
    <Data>http://altiris.ums.edu.my/Altiris/TaskManagement/CTAgent/GetClientTaskServers.aspx?resourceGuid=81a15b08-a25c-426a-a319-19516bae575e&amp;shares=1</Data>
    <Data>/Altiris/TaskManagement/CTAgent/GetClientTaskServers.aspx</Data>
    <Data>10.10.2.29</Data>
    <Data>
    </Data>
    <Data>False</Data>
    <Data>
    </Data>
    <Data>IIS APPPOOL\Classic .NET AppPool</Data>
    <Data>28</Data>
    <Data>IIS APPPOOL\Classic .NET AppPool</Data>
    <Data>False</Data>
    <Data>   at System.Web.HttpRuntime.FirstRequestInit(HttpContext context)
   at System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
</Data>
  </EventData>
</Event>
 
I have reset all the Altiris services account with the new password. All the services can start but still cannot open the Console.
 
Please advise what else I should be checking.
 

Comments 1 CommentJump to latest comment

mclemson's picture

Did you follow this procedure?
http://www.symantec.com/docs/HOWTO10009

Method 1 should work in restoring console access.  You may need to restart services and/or the server after attempting Method 1.

Does this restore console access?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com