Video Screencast Help

Unable to perform incremental backups

Created: 19 Nov 2013 • Updated: 25 Nov 2013 | 5 comments
This issue has been solved. See solution.

Hi All,

I've installed the remote agent on one of our Linux machine on the DMZ. In the beginning there were network-related issues that prevented the backups from running. I've ironed them out using the knowledge base articles. The full backups are now running on this machine; however the incremental backups are failing.

The weird thing is that when I do run it on the backup exec server manually, the incremental backup ran successfully.

I've attached the debug logs I've gathered, please could someone help me to figure this out.

Thanks very much in advace for your help and advise.

Operating Systems:

Comments 5 CommentsJump to latest comment

ADB Taipei's picture

Here's the failed job log as well, sorry I should have attached this.

AttachmentSize
failed_job_log.txt 4.56 KB
pkh's picture

What backup methods are you using?  The archive bit method is not supported on Linux servers.  You should be using the modified time method.

Also, check the SCL below and make sure that your Linux variant is supported.

BE 2012 SCL

Vishal Shinde's picture

Hi,

As the job log suggest, it seems you still have issues with the communication, as evident from the beremote debug log you have attached.

The error pointing to the fact, is as follows:

BETCPConnection::CreateConnectionFromHostAndPort: Could not create a connection to "ADBCHBACK02" because attempts with both IPv4 and IPv6 protocols failed

84da3700 Tue Nov 19 22:34:37 2013 : Could not create a BETCPConnection object from address: ADBCHBACK02 error=An error occurred during a socket connect operation: Error Code: 110, System Error Message: Connection timed out

Please re-check the port availabilities for the backup process.

Try re-creating the FULL and INCR Backup, and do change the Backup method to "modified time stamp" ,instead of "archive bit" as suggested.

Regards,

S

Vishal Shinde

Sr.Learning Consultant

Symantec Education Services

pkh's picture

Disable IPv6 on the Linux server and make sure that no other application is using port 10000

ADB Taipei's picture

Hi All,

I was able to sort this problem out by following these steps:

  • On the Backup server, click on the Backup Exec icon -> Configuration and Settings -> Backup Exec Settings.
  • Click on Network and Security on the left.
  • Tick "Enable TCP dynamic port range", and define a range. I used 65510 to 65535 .
  • Click on OK to save the settings.
  • On the server where the remote agent is installed, I opened the above-mentioned port range (65510 to 65535) to be opened to the backup exec server, the example I use are for iptable rules:
  • -A INPUT -s [backup exec server IP] -p tcp --dport 65510:65535 -j ACCEPT

The backup jobs had been running like champions.

Thanks for all the input and suggestions.

SOLUTION