Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to provision domino mailbox in EV

Created: 18 Sep 2012 • Updated: 19 Oct 2012 | 14 comments
This issue has been solved. See solution.

I had created a test provision group and target 3 mailboxes but all gets provisioned except 1.

 

Provisioning for domain 'XXXX' started at 9/19/2012 11:00:10 AM

Rank    Group name    Target name    Policy    Action

0    Group for 15 days    User1       Mailbox Policy for 15 Days    *** No mailboxes found ***
0    Group for 15 days    User2      Mailbox Policy for 15 Days    Updated mailbox for user 'CN=User2', file 'xxx\user2' on server 'CN=xxx/O=yyyy'

 

But User1 mailbox still gets provisioned under previous group which I wish to change.

1    YYYY /yyyy    Default Lotus Domino Mailbox Policy    Updated mailbox for user 'CN=User2', file 'xxxx\user2' on server 'CN=xxx/O=yyyy'

 

Anyone knows why? I had setup all 3 mailboxes settings the same way and all are enabled.

Comments 14 CommentsJump to latest comment

TonySterling's picture

So you only have one provisiong group right now?

Are there any events in the EV app log?  Could you attach the entire report?

freemanzen's picture

I have 1 default provision group for all mailboxes but created 2 more for testing purposes.

EV app log error refers to the provisioning group reports attached here.

Event ID 41288

 

AttachmentSize
EV_Domino_Mailbox_Provisioning_20120918110008.txt 3.66 KB
TonySterling's picture

You should double check the mailbox for

Cynthia Xu_ss/xxx

The Provisioning report is reporting it cannot find a mailbox for her.

freemanzen's picture

I understand that it cannot find her mailbox which is why I need to find out the reason as the default provisioning group can find her mailbox and updated perfectly.

Is very strange why it only happen to her mailbox. Tested a few more users mailbox, all got updated to the new provisioning group.

 

 

TonySterling's picture

How many Domino servers do you have?  Where is her mailbox physically located?

freemanzen's picture

only 1 domino server and all users are at the same location.

0 Group for 15 days Cynthia Xu 徐珊珊/xxx Mailbox Policy for 15 Days *** No mailboxes found ***

1 xxx/xxxx Default Lotus Domino Mailbox Policy Updated mailbox for user 'CN=Cynthia Xu 徐珊珊/O=xxx@xxx', file 'yyyy\cynthiaxu' on server 'CN=yyyy/O=xxxx'

 

Please see her mailbox is still tag to the default policy.

TonySterling's picture

Can you compare the targets on both provisioning groups to ensure they are entered identically?  It seems like the entry in the first Provisiong group is an account without a mailbox.

 

freemanzen's picture

The first group is using mailbox under Target while the second one is using Organization Unit for everyone.

But I had did the same for other mailboxes which does not face this issue.

Any other area I should check or verify as I had did the exact steps for the rest of the 5 mailboxes which all gets provisioned.

TonySterling's picture

You could try removing the target, run provisioning, and then re-add it back.

Also, could you share the version of EV adn Domino?

freemanzen's picture

Tried but still the same result.

EV v10.0.1

Domino 8.5.3

TonySterling's picture

Please grab a dtrace of EvLotusDominoPolicySyncTask and post that here?

 

freemanzen's picture

Hi Tony,

attached zip file of the dtrace.

I tested a few more mailboxes and seems that some of them also cannot be found.

AttachmentSize
TRACE_LOG_25092012_093804.zip 663.77 KB
TonySterling's picture

Does this user happen to have multiple person doc's?

The dtrace clearly shows it can't find the it for her so I wonder if your target is one without a mailbox.

562    09:38:15.506     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-M    {DominoMailboxPolicySyncTaskProcessor.ProcessUser} Processing 'person' target [Cynthia Xu 徐珊珊/bwoil]
563    09:38:15.506     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-L    {DomDatabase.OpenWithFailover} Opened DB [CN=SGMAIL/O=bwoil!!names.nsf]
564    09:38:15.506     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-M    {DomView..ctor} Opened DomView for [($VIMPeople)]
565    09:38:15.506     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-M    {DomView..ctor} Found view in database
566    09:38:15.506     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-L    {DomView.FindDocsInView} Searching for key [Cynthia Xu 徐珊珊/bwoil] in view [($VIMPeople)]
568    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <13636>    EV:L    CBaseDirectoryServiceWrapper::CreateDirectoryService() - Entry [m_nNumTries = 40]
569    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <13636>    EV:L    CBaseDirectoryServiceWrapper::CreateDirectoryService() - Successfully communicated with an EV Directory Service on the local machine
570    09:38:15.521     [1948]    (DirectoryService)    <12152>    EV:M    DIR_ADMIN_FN: CDirectoryServiceObject::get_SQLServer
571    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <13636>    EV-M    {DirectoryDBAccess.MapDNSAliasToSQLServer} DNS Alias:  ==> SQL server: evdb.bwoil.com Cached? False
573    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <13636>    EV:L    CBaseDirectoryServiceWrapper::CreateDirectoryService() - Entry [m_nNumTries = 40]
574    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <13636>    EV:L    CBaseDirectoryServiceWrapper::CreateDirectoryService() - Successfully communicated with an EV Directory Service on the local machine
575    09:38:15.521     [1948]    (DirectoryService)    <12152>    EV:M    DirectoryService: Method call: CDirectoryServiceObject::ReadDirectoryEntry, param (1E1E9814574B9774A896A6AC0A963C6AB1012j00evdg) |
576    09:38:15.521     [1948]    (DirectoryService)    <12152>    EV:L    CADOContext::CreateConnection entry
577    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-L    {DomView.FindDocsInView} Search result: (17412) Entry not found in index
578    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-M    {DomView.FindDocInView} Not found
579    09:38:15.521     [6768]    (EvLotusDominoPolicySyncTask)    <7128>    EV-L    {DomDatabase.Close} Closed DB [CN=SGMAIL/O=bwoil!!names.nsf]

But later on the task does find a person doc for that user.

You might need to contact support and have them take a look at this dtrace if that isn't it.

 

SOLUTION
freemanzen's picture

thanks for all the help. I'll check with the support and see if they can find the cause.