Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

Unable to restore data NBU 7.5

Created: 03 Oct 2012 • Updated: 03 Oct 2012 | 5 comments
This issue has been solved. See solution.

Hello,

 

I am unable to restore data from NBU 7.5, MASTER/MEDIA Sol. 10 NETBACKUP 7.5

earlier i was able to restore the same.

it is just showing

10/03/2012 17:16:54 - begin Restore
10/03/2012 17:16:55 - number of images required: 1
10/03/2012 17:16:55 - media needed: SM1181
 

tried Win/Unix all restores.

Backup  / Catalog backup is successful

Comments 5 CommentsJump to latest comment

Marianne's picture

Check for 'hung' bprd process:

bprd -dontfork -mpxmain

Every time I have experienced the exact same issue, I have noticed this bprd process.

Workaround is to cancel the restore and kill this bprd process.

Subsequent restart of restore is normally successful.

I have not been able to find the real cause or solution - once logged a call with support, but the engineer needed a level 5 bprd log. Because this issue is not seen too often, it was out of the question to leave logging at level 5 for just 'in case' the problem re-occured. The work-around is much quicker.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
RonCaplinger's picture

Marianne,

Was this just 7.5, or do you know if it is still ocurring with 7.5.0.4?

NBU2010's picture

Thanks Marianne,

I performed the steps as suggested and was able to restore the data.

By any means can we overcome this issue...like any precautions needs to be taken.

 

Thanks a ton for always giving exact solutions for the problem reported.

 

Regards

 

NBU2010's picture

Sorry forgot to mark it as a solution doing it now....smiley

Marianne's picture

I have seen this for many years across different NBU versions and different OS's on Master. Because this is an intermittent problem and the workaround is 'sort of' quick and easy, it is difficult to get a level 5 bprd log at the right time to submit to Support.

Some years ago, we saw this often enough at a customer who performed 'Recovery without Import' on a daily basis to get a call logged, to increase bprd logging level and 'all hands on deck' to monitor disk space and collect more than one bprd log at the right time to get it escalated to back-line.
A new bprd binary was issued for this particular OS (AIX) and NBU version.
The problem was never acknowledged as a 'general' problem and fix was never included for other OS's in subsequent versions.  So, I douplt that anything will be different in 7.5.0.4.

I don't know of any way to prevent this. I am aware of the issue - especially when restore is done with FORCE_RESTORE_MEDIA_SERVER in place.

If Activity Monitor sits for more than 2 minutes with 'media needed', I know what to look for...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links