Video Screencast Help

Unable to restore from Internet Explorer WebApp to users mailbox

Created: 13 Feb 2013 • Updated: 01 Mar 2013 | 9 comments
This issue has been solved. See solution.

Unable to restore from Internet Explorer WebApp to users mailbox. I get the following two Events, 8390 and 8391.

Event Type: Error
Event Source: Enterprise Vault
Event Category: Shopping Service
Event ID: 8390
Date:  2/13/2013
Time:  8:50:23 AM
User:  N/A
Computer: NGLEV1
Description:
The EnterpriseVault.DirectoryConnection object reported an error.
 
Unspecified error

Internal references:
Error 0x80004005
CDirectoryConnectionObject::ReadArchiveRetrievalTaskByMailboxDN .\DirectoryConnectionObject.cpp [lines {7106,7115,7117}], built Mar 14 10:55:02 2011

For more information, see Help and Support Center at http://evevent.symantec.com/rosetta/showevent.asp

Event Type: Error
Event Source: Enterprise Vault
Event Category: Directory Service
Event ID: 8391
Date:  2/13/2013
Time:  8:50:23 AM
User:  N/A
Computer: NGLEV1
Description:
The EnterpriseVault.DirectoryService object reported an error.
 
Unspecified error
 

For more information, see Help and Support Center at http://evevent.symantec.com/rosetta/showevent.asp

Comments 9 CommentsJump to latest comment

Data Rangler's picture

This is for Enterprise Vault 9.0.2. I have two Exchange Servers in a DAG, I am able to restore emails to one exchange server but not the other. I have refreshed the one server not working with the power shell script "SetEVExchangePermissions.ps1" but I am still unable to restore from the main EV server using the IE App

TonySterling's picture

Have you verified permission on the Shopping location?

Also, could you grab a dtrace of the shopping service when you try and do the restore?  You can attach it to your post and we can take a look.

Data Rangler's picture

Yes, I have verified the permissions on the Shopping location and I am able to restore to one of two Exchanges servers.

dtrace is attached now

AttachmentSize
trace.txt 179.72 KB
TonySterling's picture

Sorry, I mis-read two Exchange servers to be two EV servers.  blush

Could you grab another trace only this time for agentclientbroker?

JesusWept3's picture

Sounds like you may want to re run provisioning and try again

JesusWept3's picture

You need to dtrace w3wp, shopping service and directoryservice

JesusWept3's picture

I believe the error you are getting is because the EVAdmin has not been provisioned
It looks like you're trying to do a restore to its mailbox and its trying to find the exchange server that looks after it

So it has these three lines

(DirectoryService) <8848> EV:M DirectoryService: ADO: SELECT JournalTask.TaskEntryId AS JournalTaskId ,RetrievalTask.TaskEntryId AS RetrievalTaskId ,Task.ComputerEntryId AS ComputerId  FROM ExchangeMailboxEntry JOIN JournalingTarget ON ExchangeMailboxEntry.ExchangeMailboxEntryId = JournalingTarget.ExchangeMailboxEntryId JOIN JournalTask ON JournalingTarget.TaskEntryId = JournalTask.TaskEntryId JOIN RetrievalTask ON RetrievalTask.ArchivingTaskEntryId = JournalTask.TaskEntryId JOIN Task ON Task.TaskEntryId = JournalTask.TaskEntryId WHERE LegacyMbxDN = ?

(DirectoryService) <8848> EV:M DirectoryService: ADO: SELECT ArchivingRetrievalTask.TaskEntryId AS ArchiveTaskId ,RetrievalTask.TaskEntryId AS RetrievalTaskId ,Task.ComputerEntryId AS ComputerId  FROM ExchangeMailboxEntry JOIN ExchangeMailboxStore ON ExchangeMailboxStore.MbxStoreIdentity = ExchangeMailboxEntry.MbxStoreIdentity JOIN ExchangeServerEntry ON ExchangeServerEntry.ExchangeServerIdentity = ExchangeMailboxStore.ExchangeServerIdentity JOIN ArchivingRetrievalTask ON ArchivingRetrievalTask.ExchangeServerEntryId = ExchangeServerEntry.ExchangeServerEntryId JOIN RetrievalTask ON RetrievalTask.ArchivingTaskEntryId = ArchivingRetrievalTask.TaskEntryId JOIN Task ON Task.TaskEntryId = ArchivingRetrievalTask.TaskEntryId WHERE LegacyMbxDN = ?

(DirectoryService) <8848> EV:H CDirectoryServiceObject::ReadArchiveRetrievalTaskByMailboxDN - HRXEX fn trace : Error 0x80004005, .\DirectoryServiceObject.cpp [lines {19775,19784,19787,19790,19820,19823,19826,19851}], built Mar 14 10:55:02 2011.
1396 10:13:07.391  [3788] (DirectoryService) <8848> EV~E Event ID: 8391 The EnterpriseVault.DirectoryService object reported an error.| |Unspecified error| |
 

My advice would be, run a SQL Profiler and then do a a Search for those queries and see what LegacyMbxDN its passing through, because its returning no entries so the shopping service doesnt know how to process the mailbox etc

SOLUTION