Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to restore using SSR 2013 recovery disc onto RAID 5 array (suspected driver issue).

Created: 11 Nov 2013 • Updated: 11 Nov 2013 | 13 comments

We are testing Symantec System Recovery on a SBS 2003 server. The OS partition is on a RAID 5 array, and the RAID card itself is a "HighPoint RocketRAID 231x SATA controller".

Everything seems to be working properly (backups of the OS partition only take an hour and there are no error messages). Unfortunately, actually restoring the system using the live CD is proving quite challenging.

In testing, we swapped all 4 of the RAID 5 drives with spare drives, create a new RAID 5 array on the test drives, then did a recovery of the OS (using a copy of the system image stored on a connected USB drive with the Symantec live recovery CD).

Mid-recovery from the image to the test RAID array, the process hangs. I cannot remember exactly what the screen shows at that point, but it is quite early on and seems like it could have something to do with the RAID card drivers not being available for the recovery process.

Has anyone had any luck doing a system recovery with a HighPoint RAID card (or any hardware RAID), using the recovery disc?

If so, I would like to hear how you were able to include the RAID card drivers. Once we get past this, the rest should be straightforward.

Looking forward to hearing everyone's input. Thanks.

Operating Systems:

Comments 13 CommentsJump to latest comment

Markus Koestler's picture

So can you see the new RAID array when starting with the SRD ? If yes, please provide us with a screenshoot of the error message. If no you need to load the appropirate RAID driver using drvload.

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Just Another Sysadmin's picture

I just double-checked, and it was definitely due to missing SATA drivers.

The two relevant drivers are:

  • RocketRAID 231x SATA Controller
  • HighPoint RCM Device (possibly not required, but I want to make this available anyway)

I tried to create a custom SSD containing these drivers, but keep getting the following error during the image creation process:

recovery environment error.png

Ideally, I would like to slipstream these drivers into the disc, but if this takes too long to troubleshoot I will probably just use drvload and a flash drive containing the SATA drivers every time we need to do a restore.

I haven't been able to find much information online about this error. Does anyone have any ideas why I am running into problems when trying to add these drivers to my PE build?

Chris Riley's picture

Are there any errors in the system/application event logs around the time you saw this error?

Markus Koestler's picture

Hm, actually i also build custom SRDs with driver injection but my drivers work fine. For which Windows version are the drivers for the 2 devices your are adding ?

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Just Another Sysadmin's picture

@Chris: no errors in either of those two locations, although I am getting a lot of 1372 and 1528 errors under Directory Service- could that be relevant?

@Markus: SBS 2003. (I'm assuming this as I copied them straight from the driver installation directory, and the server itself is running SBS 2003.)

Chris Riley's picture

I don't think those are relevant here.

When creating a custom recovery disk, what are you using as the source - physical CD/DVD or .iso file?

Chris Riley's picture

I think the issue with creating the custom recovery disk needs more detailed investigation. I would recommend opening a support case for this.

Just Another Sysadmin's picture

Unfortunately, we are not eligible for support as we purchased our license through Techsoup (received a discount as we are a registered charity). Techsoup-acquired licenses come with no product support.

If anyone has any suggestions for things I could try, that would be fantastic!

Chris Riley's picture

In that case, reproduce the problem (error seen when creating a custom SRD) and then collect logs (http://www.symantec.com/docs/TECH54539). Attach the logs here and I will take a look to see what I can find.

Also, have you tried creating a custom SRD on a different server/workstation to see if this works?

Just Another Sysadmin's picture

Which options should I enable for the log collection? Are the defaults enough? (I tried enabling everything but it created a log folder of size 143 MB.)

 

Symantec Gather Utility options.png

I was actually thinking of creating a custom SRD on a different workstation, but I didn't think that would prove much as the HighPoint RAID card (where we are running into driver problems) is only present on the server. For some reason I assumed it wouldn't work unless I created the disk on the machine I was going to be doing the restore on (i.e. the server).

On second thoughts, I should be able to go through the same driver inclusion process even if the hardware isn't present on the other machine (I'll just manually select the drivers instead of letting it auto-detect them as it does if the hardware was present). I'll give that a try this morning.

Chris Riley's picture

Just accept the defaults - should not be anywhere near 143MB.....