Video Screencast Help

Unable to see Oracle instance name in remote agent utility

Created: 30 Mar 2014 • Updated: 08 Apr 2014 | 9 comments
This issue has been solved. See solution.

Hello 

 

We are trying to configure the oracle backup using BE2012. We have installed remote agent on our win2008r2 with oracle 11g. But while configuring oracle thru remote agent utility we are unable to see the oracle intance it shows blank. Please let us know if something is missing from backup exec or windows side or oracle configuration.

Operating Systems:

Comments 9 CommentsJump to latest comment

sidd3009's picture

Hello,

If the settings are based on http://www.symantec.com/docs/TECH49969 and http://www.symantec.com/docs/TECH60001 then you should be able to view the instance. 

Note: You need to ensure that you have Backup Exec 2012 Service Pack 4 installed on the Backup Exec server and pushed on the Remote Server as well : http://www.symantec.com/docs/TECH212772

Regards,

Siddhant Saini
Advanced Technical Support Engineer, Symantec Corporation 
www.symantec.com

WikiDonor's picture

I am trying to configure oracle settings thru remote agent utility and there I cannot see my oracle instance its blank. 

If you find my comment informative and helpful please mark the post as resolved.

sidd3009's picture

Can you try to add it manually(enter the SID manually)? 

From the Remote Agent Utility > Go to the Oracle Tab > Click on New and add the Local Instance Name Manually. 

Regards,

Siddhant Saini
Advanced Technical Support Engineer, Symantec Corporation 
www.symantec.com

WikiDonor's picture

Even if I type it manualy it does not work. The Remote agent console shuts off as soon as I click OK to submit the changes.

 

 

If you find my comment informative and helpful please mark the post as resolved.

WikiDonor's picture

The article seems to be for linux OS not windows. I am using oracle on windows server.

If you find my comment informative and helpful please mark the post as resolved.

lmosla's picture

WikeDonor,

Make sure all of the Backup Exec updates are installed.

Try uninstalling and reinstalling agent also see if this document is useful http://www.symantec.com/docs/TECH7563

Hope this helps

 

SuperBrain's picture

Hi WikiDonor,

Check one of the following to make sure the configurations on Oracle with regards to the instance are good:

  1. Ensure Oracle services are running
     
  2. Ensure the Oracle instance(s) in question is started
     
  3. In case your Oracle executables have been moved to another drive or directory recently, The services are defnied in the Windows Registry. The IMAGEPATH parameter/key contains the path and executable name of that service:
     
    • Start - Run - regedit

      Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
       

    • Look in HKEY_LOCAL_MACHINE | SYSTEM | CURRENTCONTROLSET | SERVICES
      Here, you will see a list of all services on your machine.
    • Find your oracle services there and look for the IMAGEPATH key and compare it to where you have your Oracle instance on disk.
    • If the path is incorrect, fix the path and exit the registry.

After confirming all of the above, you can attempt to configure the Oracle via the remote agent utility to check if you see your instance.

Let us know if any of the above helped or if you run into any other issue while configuring your oracle backups.

SOLUTION
WikiDonor's picture

I found this under image name path.

 

"c:\oracle\product\11.2.0\dbhome_1\bin\ORACLE.EXE"InstanceName

 

I checked same path on one of my working oracle servers.

I did'nt see a doublecoat in the path

I changed the path c:\oracle\product\11.2.0\dbhome_1\bin\ORACLE.EXE InstanceName 

Now I am able to see the instance during configuration.

 

Thank you very much SuperBrain

If you find my comment informative and helpful please mark the post as resolved.