Video Screencast Help

unable to select disk in restore

Created: 30 Jun 2011 • Updated: 30 Jun 2011 | 10 comments
millaard's picture

Hi All!

I've got a strange issue, I'll try to explain.

I've got Backup Exec 2010 R2 running on our backup machine which is also running VMware vCenter (4.1U1). I’m backing up different VM’s with the Agent for VMware. I’ve also got the BE Windows agent installed on the VM’s.

When I try to restore files on different servers this is not a problem, accept for 1 server. This specific server has got 4 vmdk disks on the same VMFS store, only the size of these disks defer. This server is running Windows 2008 R2 SP1 Enterprise. When I try to restore files on this server I’m only able to select files from the vmdk disk where the OS lives. The other disks do not appear in the restore selection list. I’m able to restore the complete vmdk however.

What can I do to restore files directly from the 2nd, 3rd or 4th vmdk disk without having to restore the complete vmdk, mount it etc.? How can I make this disks reappear in the selection list?

Kind regards,

 

Harm Peter Millaard

Comments 10 CommentsJump to latest comment

Riyaj S's picture

I think your issue might be related to the one mentioned in the Technote :

http://www.symantec.com/docs/TECH166833

Have you tried restoring any VM with multiple disks ?

 

Try out the new Backup Exec Support Tool that diagnoses many common issues found in Backup Exec and Symantec System Recovery environments. 
 
http://www.symantec.com/docs/TECH126539
Colin Weaver's picture

When you stated that the disks were in the same vmfs store - did you mean the same store but individual VMDK files - or did you mean one vmdk file that is partitioned and contains multiple logical windows volumes?

sbora's picture

In the backup job log (for backup job which backed up this virtual machine) do you see any exceptions or errors? You are not able to see the GRT information for 2nd, 3rd and 4th VMDK so it is possible that the job failed during GRT processing of the 2nd, 3rd and 4th vmdk.

Simon B.'s picture

Are these other disks by any chance configured as independant disks or raw device mappings (RDM)? These types are not supported by the AVVI Agent. You would need to backup these volumes seperatly via RAWS

PMCS GmbH & Co. KG - Consulting und Support für BE/NBU/EV und andere Symantec Produkte.
Please take the time and mark this post as solution if it solved your problem - thanks!

pkh's picture

Guys, the original question was posted on 30 June and I doubt the user is hanging around the forum for his answer or to answer your questions.

millaard's picture

Hi Guys,

I'm really sorry I didn't react as fast as I would have done, if I had received any email alerts on this post...

Well, the problem isn't solved yet... To make the problem more clear, I've attached some screenprints.

All disks are configured like this on the VM:

 If I want to restore the individual VMDK's, that's fine!

 

But If I want to restore files in those VMDK's, there not selectable... And that's my problem.

The logfiles contain only successfull backups without any GRT error's. But these logfiles also state:

Backup Exec has discovered and protected 'C:' on virtual machine '\\EEND-FS01'

The other partitions, D: E: and F: are not mentioned for EEND-FS01...This might be our first clue...

On all other servers these partitions and applications like SQL and Exchange, are correctly mentioned in the logfiles.

I wonder how I can we fix this?

Kind regards,

 

Harm Peter Millaard

pkh's picture

If you want any e-mail alerts, you should subscribe to this discussion.  Use the Subscriptions link below.

sbora's picture

Can you also paste a screenshot from Disk Management within the VM showing all the partitions? Also if you can paste (or upload the job log) the backup job log contents showing details of this VM it will help.

millaard's picture

Here are the screenprints you asked for...

Also a recent logfile is attached in XML form.

AttachmentSize
BEX_VC01_00451.xml 68.42 KB
samueljn's picture

Hi Milliard,

As we discussed today, you can upgrade Backup exec and the remote agents to BE 2010 R3. But before that, i would suggest you to test by reinstalling Vmware tools on this particular VM. When you reinstall, make sure that you deselect File system sync driver and VM Snapshot.

This process requires 2 reboots of the VM (One during uninstall and another after reinstall).

Regards,

John Samuel M