Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Unable to stop all EV services in File Server

Created: 08 Jan 2013 • Updated: 15 Jan 2013 | 6 comments
This issue has been solved. See solution.

Hi Everyone,

Can anyone please explains to me as to why I cannot STOP all EV services in my Windows Server 2008 Enterprise cluster Fileserver ?

I have tried in both nodes but so far I cannot stop the following services:

  • Enterprise Vault File Blocking Service
  • Enterprise Vault File Collector Service
  • Enterprise Vault File Placeholder Service

Because when I stop the service sequentially from that list above, It will auto start again ? I also have tried randomly but it is also started again after few seconds.

The reason I need to stop that is to allow successful cluster failover to different node since we have some issues.

is this a bug in EV 8.0 SP4 ?

Comments 6 CommentsJump to latest comment

JesusWept3's picture

Are you using VCS or MSCS?
It sounds to me as if its the clustering software thats keeping the services started

Can you not just fail over through the console which will take the services offline itself?

John Santana's picture

Hi Jesus,

The MSCS is somehow having issue itself, I tried to connect usingthe MSCS name but it doesn't allow me to do the cluster management. STOPping from the services.msc doesn't allow me as well.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

JesusWept3's picture

Do you have the Enterprise Vault Admin Service on that machine?
I tried it on mine and it is the AdminService monitoring the FSA Services and starting them if stopped

37 19:23:17.692 [3092] (AdminService) <3160> EV:M StartProcessesInList() - Finding the process entry whose handle became invalid in g_szProcessEntries
38 19:23:17.692 [3092] (AdminService) <3160> EV:M StartProcessesInList() - The process that terminated is = FSAReportingService.exe
39 19:23:17.692 [3092] (AdminService) <3160> EV:M Checking if process = FSAReportingService.exe, cmdLine = should be launched
40 19:23:17.692 [3092] (AdminService) <3160> EV:M ShouldProcessBeLaunched() - process = FSAReportingService.exe, cmdLine =
41 19:23:17.692 [3092] (AdminService) <3160> EV:M MaxRetries = 3, CurrentRetryCount = 3

SOLUTION
John Santana's picture

Hi,

No I do not have Enterprise Vault Admin Service ? I guess its on different version of EV ?

The solution was to DISABLE the service startup and then stoping it manually.  

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

JesusWept3's picture

no, i think its because I had the Sharepoint Services installed that the admin service was there, however it was most likely the EV server itself keeping it started for the Reporting file collection services.

you could also try disabling the reporting for that server temporarily, but something tells me there has to be something more simple than this

John Santana's picture

I guess the MSCS service causing them to start whenit is stopped.

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.