Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

unable to take the backup in standalone drive using netbackup

Created: 16 Nov 2012 • Updated: 17 Dec 2012 | 12 comments
This issue has been solved. See solution.

Trying to take the backup using veritas netbackup tool which is attached with a standalone drive. Though I have inserted the media  its thoughing error 96 when I fire the backup.

 

I have labeled the media manually using the GUI.  when I gio to label the tape using below command i get the erroe messages

 

bplabel -m A00001 -d hcart -o -p NetBackup -u 0

Error:Error reported by media operation:resource request failed

Comments 12 CommentsJump to latest comment

sazz.'s picture

This error comes when media is not in the specified pool. Please check the media exist in the NetBackup pool, if not mention the pool in which it exists while running the command.

Also make sure Bplable will erase all the data on tape

96 error  -> make sure the media density and drive density should match.

Marianne's picture

Try to follow these steps that I have shared in another post:

Say you have 6 physical tapes and you decide to put labels/stickers on them:

A00001
A00002
A00003
A00004
A00005
A00006

Go to Media section of the GUI and add new volumes: A00001 - 6
Ensure the media density matches that of the tape drive and select a pool (e.g. NetBackup).

Once added, you insert tape A00001 into the tape drive, wait for the 'Ready' light on the drive, then use bplabel:
bplabel -m A00001 -d hcart -o -p NetBackup -u 0
(replace hcart  with density selected above and NetBackup with the pool that you have added tape to.)

Repeat for rest of tapes.

Also see this post: https://www-secure.symantec.com/connect/forums/netbackup-70-standalone-drive#comment-4235181 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

cynthiapinto's picture

Thanks Marianne/Sazz

 

I tried the procedure you gave but I get the below error though I have inserted the new tape in the standalone drive.

Error:Error reported by media operation:resource request failed

 

 Before attaching the the standalone drive to the server I was using the Tape library with robotics Now the tape library is gone bad I connected the standalone drive. As I am using the same netbackup setup will this  cause any problem? bcz I had no problem when I was using the tape library.  

sazz.'s picture

Yes it will, the old tapes that were used in the library were have barcodes but the standalone is not able to read the barcodes.

If you will be using the old tapes to restore the data or to write the data once these are expired you have to do physical inventory.

http://www.symantec.com/docs/TECH56903



For the new tapes that were not used in the NBU before you can do the procedure mentioned above by Marianne. Also please don't do the bplable if you have data on those tapes as all the data will be lost. I guess as of now you just use the standalone for restore and get your library fixed asap.

 

Marianne's picture

Please show us output of the following with tape in the drive and 'ready' light on:

vmoprcmd -d

As well as :

vmquery -a -bx

Please also let us know OS on this server and your NBU version.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

cynthiapinto's picture

Hi Sazz,

 

We many not repair the tape library as the project is ramped down so we are using the existing Standalone drive. Even I need to reuse the expired tapes whicha re used in robotics. 

 

Hi Marianne,

The server OS is Solaris 9 & the VNB is 6.0MP4

Here is the o/p of the commands

 

axes-mach01:root://> vmoprcmd -d

                                PENDING REQUESTS

ReqId      User    RecMID  ExtMID  Density  Mode    Time   Barcode   VolGroup  
5251                       A00001  hcart3   Write   17:59  --------  ---       

                                  DRIVE STATUS

Drv Type   Control  User      Label  RecMID  ExtMID  Ready   Wr.Enbl.  ReqId
  0 hcart3   AVR               Yes   F344L3           Yes     Yes        0  

                             ADDITIONAL DRIVE STATUS

Drv DriveName            Shared    Assigned        Comment                   
  0 IBM.ULTRIUM-TD3.000   No       -                                         
axes-mach01:root://> vmquery -a -bx
media   media     robot  robot  robot  side/  volume      optical  # mounts/        last            assigned       pool
 ID     type      type     #    slot   face   group       partner  cleanings     mount time          time
---------------------------------------------------------------------------------------------------------------------------
0805S1  DLT       NONE     -      -     -     ---           -           1     08/05/2005 17:09  08/05/2005 17:07  Aug05-Yearly-Inf    
0805S2  DLT       NONE     -      -     -     ---           -           1     08/05/2005 20:42  08/05/2005 17:07  Aug05-Yearly-Inf    
0805S3  DLT       NONE     -      -     -     ---           -           1     08/06/2005 01:12  08/05/2005 17:07  Aug05-Yearly-Inf    
0805S4  DLT       NONE     -      -     -     ---           -           1     08/06/2005 05:54  08/05/2005 17:07  Aug05-Yearly-Inf    
0805S5  DLT       NONE     -      -     -     ---           -           1     08/06/2005 13:29  08/05/2005 17:07  Aug05-Yearly-Inf    
0806S1  DLT       NONE     -      -     -     ---           -           2     12/15/2006 09:25  08/11/2006 15:16  Aug05-Yearly-Inf    
0806S2  DLT       NONE     -      -     -     ---           -           2     12/15/2006 12:11  08/11/2006 15:16  Aug05-Yearly-Inf    
0806S3  DLT       NONE     -      -     -     ---           -           2     12/15/2006 14:47  08/11/2006 15:16  Aug05-Yearly-Inf    
0806S4  DLT       NONE     -      -     -     ---           -           2     12/15/2006 19:27  08/11/2006 15:16  Aug05-Yearly-Inf    
0806S5  DLT       NONE     -      -     -     ---           -           2     12/15/2006 21:54  08/11/2006 15:16  Aug05-Yearly-Inf    
0806S6  DLT       NONE     -      -     -     ---           -           2     12/16/2006 00:53  08/11/2006 15:16  Aug05-Yearly-Inf    
0807Y1  DLT       NONE     -      -     -     ---           -           2     12/10/2007 10:38  08/03/2007 21:57  yearly              
0807Y2  DLT       NONE     -      -     -     ---           -           1     08/04/2007 01:55  08/04/2007 00:02  yearly              
0807Y3  DLT       NONE     -      -     -     ---           -           1     08/04/2007 05:02  08/04/2007 00:02  yearly              
0807Y4  DLT       NONE     -      -     -     ---           -           1     08/04/2007 10:15  08/04/2007 00:02  yearly              
0807Y5  DLT       NONE     -      -     -     ---           -           1     08/04/2007 14:01  08/04/2007 00:02  yearly              
0807Y6  DLT       NONE     -      -     -     ---           -           1     08/04/2007 19:15  08/04/2007 00:02  yearly              
0807Y7  DLT       NONE     -      -     -     ---           -           1     08/04/2007 21:37  08/04/2007 00:02  yearly              
A00001  HCART3    NONE     -      -     -     ---           -           0     00/00/0000 00:00     ---      ---   NetBackup           
AX0742  DLT       NONE     -      -     -     ---           -           4     11/20/2007 13:02  11/20/2007 11:09  Weekly              
AX2S5   DLT       NONE     -      -     -     ---           -           1     10/07/2005 09:40  10/07/2005 09:38  axess2              
F342L3  HCART3    NONE     -      -     -     ---           -           9     10/30/2008 16:00  05/27/2008 15:00  yearly              
F344L3  HCART3    NONE     -      -     -     ---           -           1     11/19/2012 11:21  11/19/2012 11:21  Daily               
F350L3  HCART3    NONE     -      -     -     ---           -          44     09/12/2010 02:40  09/11/2010 13:39  yearly              
F351L3  HCART3    NONE     -      -     -     ---           -          24     06/12/2009 10:19  02/13/2009 19:58  Weekly              
F352L3  HCART3    NONE     -      -     -     ---           -           0     00/00/0000 00:00     ---      ---   Daily               
F355L3  HCART3    NONE     -      -     -     ---           -          26     02/19/2009 22:17  02/14/2009 11:02  Weekly              
F356L3  HCART3    NONE     -      -     -     ---           -          12     11/13/2009 12:26  01/24/2009 11:48  yearly              
F357L3  HCART3    NONE     -      -     -     ---           -          22     11/29/2009 05:11  09/12/2009 04:54  Weekly              
F358L3  HCART3    NONE     -      -     -     ---           -           3     08/04/2008 18:30  08/02/2008 09:09  yearly              
F359L3  HCART3    NONE     -      -     -     ---           -           9     06/30/2009 14:39  07/31/2008 18:07  yearly              
F361L3  HCART3    NONE     -      -     -     ---           -          45     07/10/2011 03:50  07/08/2011 19:00  yearly              
F362L3  HCART3    NONE     -      -     -     ---           -          64     12/31/2009 13:33  09/04/2009 19:00  yearly              
F366L3  HCART3    NONE     -      -     -     ---           -           4     11/14/2012 11:32  10/17/2012 12:54  Weekly              
F367L3  HCART3    NONE     -      -     -     ---           -          35     03/02/2011 20:10  02/08/2011 17:02  yearly              
F368L3  HCART3    NONE     -      -     -     ---           -           8     12/31/2009 12:23  09/05/2009 03:44  yearly              
F370L3  HCART3    NONE     -      -     -     000_00000_    -         329     04/03/2012 23:27  04/08/2011 10:57  NetBackup           
F372L3  HCART3    NONE     -      -     -     ---           -           2     04/09/2009 12:48  04/09/2009 12:46  yearly              
F373L3  HCART3    NONE     -      -     -     ---           -           2     11/09/2012 11:52  11/08/2012 16:04  yearly              
F375L3  HCART3    NONE     -      -     -     ---           -          32     03/28/2011 15:39  01/29/2011 18:02  Weekly              
F400L3  HCART3    NONE     -      -     -     ---           -          59     07/08/2011 19:02  07/08/2011 19:00  yearly              
F401L3  HCART3    NONE     -      -     -     ---           -          24     02/09/2011 15:03  12/21/2010 13:19  yearly              
F402L3  HCART3    NONE     -      -     -     ---           -           8     09/11/2010 10:42  06/10/2010 13:23  yearly              
F403L3  HCART3    NONE     -      -     -     000_00000_    -          20     03/09/2012 18:37  01/31/2011 10:30  Weekly              
M10RS1  DLT       NONE     -      -     -     ---           -           3     08/12/2005 10:47  02/21/2005 07:09  axes-mach10         
M1RS1   DLT       NONE     -      -     -     ---           -           3     08/12/2005 08:53  02/21/2005 19:56  axes-mach01         
N660L1  HCART3    NONE     -      -     -     ---           -           0     00/00/0000 00:00  02/19/2011 14:35  Weekly            

 

Marianne's picture

You have a pending request for A00001 but the tape in the drive already has an internal label:

 

axes-mach01:root://> vmoprcmd -d

                                PENDING REQUESTS

ReqId      User    RecMID  ExtMID  Density  Mode    Time   Barcode   VolGroup  
5251                       A00001  hcart3   Write   17:59  --------  ---       

                                  DRIVE STATUS

Drv Type   Control  User      Label  RecMID  ExtMID  Ready   Wr.Enbl.  ReqId
  0 hcart3   AVR               Yes   F344L3           Yes     Yes        0  

 

F344L3 already exists in the Media database in the Daily pool and is Assigned (Assign time 11/19/2012 11:21)

F344L3  HCART3    NONE     -      -     -     ---           -           1     11/19/2012 11:21  11/19/2012 11:21  Daily               

This means that tape F344L3 was either used for backups today or got frozen because of the attempt to re-label it as A00001.

To know the NBU status, run this command:

nbemmcmd -listmedia -mediaid F344L3

Why not use the tape with its 'known' media ID (F344L3) that probably corresponds with the external label?

Steps going forward will depend on nbemmcmd command output and your choice between using it as A00001 or F344L3.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

sazz.'s picture

its pending and why you want to lapel the tape if it has got one, make sure it will erase the data out of it.

Also why you want to relabel these when they already have the labels, you can use these tapes without labeling them again.

Edit : Oops, sorry Marianne already wrote a big explanation while I was stuck on a call. 

Mark_Solutions's picture

Also please note that your original command used hcart as the density but that output showsA00001 to be hcart3 so the command would not have worked due to the density mismatch.

Hope this also helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

cynthiapinto's picture

Hi,

I have no problem using the existing label. As I was facing the problems I thought of relabeling the tape. 

Yes when I run the command "nbemmcmd -listmedia -mediaid F344L3" I could see the tape was in frozen state. I unfreezed it using the bpmedia command & initiated the backup with the media label F344L3.

But  after connecting it gives me a error "Warnign bptm Freezing media F344L3, It contains netbackup database backup data & cannot be used for backups" . I expired the tape & tried to reuse but no luck .

 

My doubt is 

 

Cant i use the frozen tape again ? 

 

Marianne's picture

This is your problem:

 

... It contains netbackup database backup data & cannot be used for backups

This means that this tape was used for cold catalog backups. special steps are needed to reuse cold catalog tapes.

Symantec's knowledge base is current offline, so I cannot access the TN's describing the steps.

In short, you need to deassign the tape, then relabel it with -o option to force the overwrite.

1. Determine the volume pool number and status.  Use: 
/usr/openv/volmgr/bin/vmquery -m <media-id>

2. De-assign the volume
/usr/openv/volmgr/bin/vmquery  -deassignbyid <media_id> <pool_number> <status>

3. Relabel media: 
/usr/openv/netbackup/bin/admincmd/bplabel bplabel -m <media-id> -d hcart3 -o -p <pool> -u 0

 

PS: I am surprised to see this tape is in the Daily pool? Cold catalog tapes are normally in the NetBackup pool.

**** EDIT ****

TechNote with detailed steps to  recycle offline cold catalog backup media: http://www.symantec.com/docs/TECH56392

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Mark_Solutions's picture

What version of NetBackup are you on?

If you are on a version that still supports cold catalog backups then go to the catalog section, right click and go into the cold catalog backup section and remove the tape from that selection (if it is there)

This will effectively de-assign it from use and free it up for you to re-use.

Once this is done you should be able to follow Mariannes excellent advice to deassign it after which you can relabel it - use the verify option or do it from the command line which allows you to overwrite it - but do bear in mind that this is a catalog backup so make sure you do not actually need it

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.