Video Screencast Help

Unable to up the tape drives on the windows media server

Created: 27 May 2013 • Updated: 22 Aug 2013 | 7 comments
This issue has been solved. See solution.


All the drives are in down state.Its a media server (windows 2003 server).

I have restarted Netbackup services on the media server.

after that  I tried to up the drives using vmoprcmd but not coming up.

C:\Program Files\VERITAS\Volmgr\bin>vmoprcmd.exe -d
                                PENDING REQUESTS
                                  DRIVE STATUS
Drv Type   Control  User      Label  RecMID  ExtMID  Ready   Wr.Enbl.  ReqId
  0 hcart3  DOWN                -                     No       -         0
  1 hcart3  DOWN                -                     No       -         0
  2 hcart3  DOWN                -                     No       -         0
  3 hcart3  DOWN                -                     No       -         0
  4 hcart3  DOWN                -                     No       -         0
                             ADDITIONAL DRIVE STATUS
Drv DriveName            Shared    Assigned        Comment
  0 Rob3-F1-Drv1A         Yes      -
  1 Rob3-F1-Drv2A         Yes      -
  2 Rob3-F1-Drv3A         Yes      -
  3 Rob3-F1-Drv4A         Yes      -
  4 Rob3-F2-Drv13A        Yes      -
C:\Program Files\VERITAS\Volmgr\bin>vmoprcmd.exe -up 0 -h FNPESGO01
Invalid Drive Number
C:\Program Files\VERITAS\Volmgr\bin>

Can you please share your suggestions what I need to do to get them up...

Operating Systems:

Comments 7 CommentsJump to latest comment

revarooo's picture

Delete the drives in NetBackup.

Delete the drives in OS Device Manager.

Re-scan for hardware changes in OS Device Manager

Ensure drivers are upto-date

Re-configure in Netbackup

tpram@Backup's picture

It showing as the missing path as below.

C:\Program Files\VERITAS\Volmgr\bin>tpconfig.exe -d
Id  DriveName           Type   Residence
      SCSI coordinates/Path                                            Status
0   Rob3-F1-Drv1A        hcart3 TLD(3)  DRIVE=1
      MISSING_PATH:{1,0,0,0}:0007808867                                DOWN
1   Rob3-F1-Drv2A        hcart3 TLD(3)  DRIVE=2
      MISSING_PATH:{1,0,1,0}:0007808814                                DOWN
2   Rob3-F1-Drv3A        hcart3 TLD(3)  DRIVE=3
      MISSING_PATH:{1,0,2,0}:0007808859                                DOWN
3   Rob3-F1-Drv4A        hcart3 TLD(3)  DRIVE=4
      MISSING_PATH:{1,0,3,0}:0007810088                                DOWN
4   Rob3-F2-Drv13A       hcart3 TLD(3)  DRIVE=13
      MISSING_PATH:{1,0,4,0}:0007816591                                DOWN

Nicolai's picture

You can't "up" the drives because of the"MISSING_PATH:" error message. The tape drives are not at the address Netbackup expect. It's like when you phone someone and they moved to another state with a different area code. 

As already suggested delete all the drives and run the device wizard.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Possible's picture

Go to devices--drives--delete affected drives

go to the device config wizard---reconfigure the drives.

it will do for u.

revarooo's picture

When you have rediscovered the drives, ensure you have persistant binding set at the HBA .

Marianne's picture

All the drives are in down state.Its a media server (windows 2003 server).

In addition to above excellent advice, please check that Removable Storage service is stopped and disabled.

Persistent Binding at HBA level is extrememly important to ensure that device addresses remain the same across reboots.

Best to use Vendor drivers for tape drives.

Check Event Viewer System and Application logs for errors.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links