Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Unable tp upgrade SEE FD from version 7.x to version 8.x

Created: 10 Jul 2013 | 6 comments
cetnamys19's picture

HI Guys,

Can anyone already know this error? Error 25021. The current version of Symantec Endpoint Encryption Full Disk Edition Client is not compatible with the version of installed SEE Framework Client.

I upgraded the SEE Management Server from 7.x to 8.x following the proper sequence (1st SEE Manager, 2nd SEE Framework, 3rd SEE FD, 4th SEE RS) and procedure like invoking msi parameter in installer (msiexec /i "seefd.msi" reinstall="all" reinstallmode="vomus") . After creating the new package, I'm able to upgrade the SEE Client's Framework and SEE RS but not the SEE FD.

See attached for the error.

 

Thanks,

N

Operating Systems:

Comments 6 CommentsJump to latest comment

SMLatCST's picture

What exact version are you trying to install now?

I'm sure you've already tried this, but I'd suggest re-exporting the FC (Framework Client) and FD (Full Disk) client packages from the server and trying again.

Also, can you confirm what version the FC the client thinks it's running?  Perhaps the FC upgraded hadn't completed yet?

cetnamys19's picture

 

I already tried re-exporting the FC and FD, the FC and RS is already 8.2 MP2. I'm wondering how does FD not able to upgrade while RS is able to upgrade without any problem in FC.

SMLatCST's picture

It's not an issue I've encountered myself, and doesn't appear to be a known issue either (at least my searches failed to unearth it sad), if that's what you're asking.

Assuming the SEE Manager Console upgrade completed successfully and the client packages are all valid and correct, then the only thing I can think of is that there are perhaps legacy registry entries that the FD client looks for that RS does not.

You don't have the older client still being pushed by GPO or anything do you?

I think this might well be a job for Symantec Support I'm afraid!

cetnamys19's picture

I look on the registry of framework and it doesnt show the version and build 8.2, it still shows 7.0, so when i upgrade the FD using the new package it tells that the framework is incompatible. I tried to change the registry of the FC (version and build to 8.2) and reinstall the FD, it doesnt show the error message but it rolls back. I will try the manual installation instead of GPO for FC and check what will happen.

cetnamys19's picture

Hey I successfully upgrade the client by manually installing the FC,FD and rs. I think the problem is in the GPO, once I deploy the FC thru GPO and tried to upgrade it, it seems it cannot properly upgrade the FC of the computer and I cannot uninstall the FC from the computer. So i set up a computer from scratch and initially install the FC, FD and RS and then upgraded it from 7 to 8 and works fine without using GPO for deployment.

SMLatCST's picture

Ahhhh it was a GPO thing!

It's good to know the cause is now clear.  I'm not sure if this helps, but have you seen the below article?

http://www.symantec.com/docs/TECH152234

Seems semi-useful in the steps it provides, but it appears to make no mention of the "reinstall=all" "reinstallmode=vomus" bits, so I'm useure how accurate it is.

Perhaps you could enable logging to get a better view of where it's going wrong:

http://www.symantec.com/docs/TECH104165

Also, for those deployed with SEE by GPO, did you block/unlink/disable the GPO from applying to the machine when attempting the manual upgrades before?